File: changelog

package info (click to toggle)
ruby-packetfu 1.1.11-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 2,972 kB
  • ctags: 1,249
  • sloc: ruby: 7,714; makefile: 2
file content (66 lines) | stat: -rw-r--r-- 2,470 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
ruby-packetfu (1.1.11-2) unstable; urgency=medium

  * Team upload.
  * Create patch fixing tests with ruby2.3 (Closes: #816254)
  * d/copyright: add Upstream-Contact and set up upstream email
  * Update Debian packaging copyright
  * Declare compliance with Debian policy 3.9.7

 -- Lucas Kanashiro <kanashiro.duarte@gmail.com>  Mon, 29 Feb 2016 16:36:03 -0300

ruby-packetfu (1.1.11-1) unstable; urgency=low

  * New upstream version.
  * Ship some upstream documentation.
  * Update debian/copyright.
  * Tighten pcaprub dependency.
  * Refresh and drop obsolete patches.
  * Add a patch to use Ruby 2.1+ new API instead of the unpackaged
    network_interface library.
  * Update Vcs-Git URL.
  * Switch to debhelper compat level 9.
  * Override lintian regarding the OUI database. It's only present in the
    source and shipped in the binary package.

 -- Jérémy Bobbio <lunar@debian.org>  Thu, 10 Sep 2015 16:46:27 +0200

ruby-packetfu (1.1.10-2) unstable; urgency=medium

  * Team upload
  * Update packaging with dh-make-ruby -w
    + Bump Standards-Version to 3.9.6 (no changes needed)
  * Build-depend on ruby-rspec >=3 and ruby-rspec-its (Closes: #795044)
  * Drop dependency on ruby-rspec (not needed)
  * Patches:
    + refresh 0001-Be-better-about-version-checking-multidigits.patch
    + refresh 0002-Do-not-require-rubygems-even-with-Ruby-1.8.patch
    + add 0004-Port-to-rspec3.patch (upstream) adding support for rspec3
    + add 0005-Require-rspec-its.patch to explicitly load rspec/its
  * Restrict examples to Ruby files and symlink oui.txt from ieee-data package

 -- Cédric Boutillier <boutil@debian.org>  Mon, 10 Aug 2015 01:27:34 +0200

ruby-packetfu (1.1.10-1) unstable; urgency=low

  * New upstream version.
  * Drop an obsolete patch.
  * Import upstream patch to fix test suite compatibility with version
    numbers and Ruby 2.x.
  * Re-enable support for all versions. (Closes: #725675, #746098)
  * Update homepage location.
  * Bump Standards-Version, no changes required.

 -- Jérémy Bobbio <lunar@debian.org>  Sat, 03 May 2014 15:12:08 +0200

ruby-packetfu (1.1.8-2) unstable; urgency=low

  * Only provide ruby1.9.1 compatibility until issues with ruby2.0 are sorted
    out. (Closes: #725556)

 -- Jérémy Bobbio <lunar@debian.org>  Mon, 07 Oct 2013 11:20:01 +0200

ruby-packetfu (1.1.8-1) unstable; urgency=low

  * Initial release. (Closes: #719297)

 -- Jérémy Bobbio <lunar@debian.org>  Sat, 24 Aug 2013 19:25:47 +0200