File: poltergeist.gemspec

package info (click to toggle)
ruby-poltergeist 1.10.0-1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 332 kB
  • ctags: 333
  • sloc: ruby: 1,374; makefile: 3
file content (77 lines) | stat: -rw-r--r-- 5,060 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
#########################################################
# This file has been automatically generated by gem2tgz #
#########################################################
# -*- encoding: utf-8 -*-
# stub: poltergeist 1.10.0 ruby lib

Gem::Specification.new do |s|
  s.name = "poltergeist"
  s.version = "1.10.0"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.require_paths = ["lib"]
  s.authors = ["Jon Leighton"]
  s.date = "2016-06-27"
  s.description = "Poltergeist is a driver for Capybara that allows you to run your tests on a headless WebKit browser, provided by PhantomJS."
  s.email = ["j@jonathanleighton.com"]
  s.files = ["LICENSE", "README.md", "lib/capybara/poltergeist.rb", "lib/capybara/poltergeist/browser.rb", "lib/capybara/poltergeist/client.rb", "lib/capybara/poltergeist/client/agent.coffee", "lib/capybara/poltergeist/client/browser.coffee", "lib/capybara/poltergeist/client/cmd.coffee", "lib/capybara/poltergeist/client/compiled/agent.js", "lib/capybara/poltergeist/client/compiled/browser.js", "lib/capybara/poltergeist/client/compiled/cmd.js", "lib/capybara/poltergeist/client/compiled/connection.js", "lib/capybara/poltergeist/client/compiled/main.js", "lib/capybara/poltergeist/client/compiled/node.js", "lib/capybara/poltergeist/client/compiled/web_page.js", "lib/capybara/poltergeist/client/connection.coffee", "lib/capybara/poltergeist/client/main.coffee", "lib/capybara/poltergeist/client/node.coffee", "lib/capybara/poltergeist/client/web_page.coffee", "lib/capybara/poltergeist/command.rb", "lib/capybara/poltergeist/cookie.rb", "lib/capybara/poltergeist/driver.rb", "lib/capybara/poltergeist/errors.rb", "lib/capybara/poltergeist/inspector.rb", "lib/capybara/poltergeist/network_traffic.rb", "lib/capybara/poltergeist/network_traffic/error.rb", "lib/capybara/poltergeist/network_traffic/request.rb", "lib/capybara/poltergeist/network_traffic/response.rb", "lib/capybara/poltergeist/node.rb", "lib/capybara/poltergeist/server.rb", "lib/capybara/poltergeist/utility.rb", "lib/capybara/poltergeist/version.rb", "lib/capybara/poltergeist/web_socket_server.rb"]
  s.homepage = "https://github.com/teampoltergeist/poltergeist"
  s.licenses = ["MIT"]
  s.required_ruby_version = Gem::Requirement.new(">= 1.9.3")
  s.rubygems_version = "2.5.1"
  s.summary = "PhantomJS driver for Capybara"

  if s.respond_to? :specification_version then
    s.specification_version = 4

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<capybara>, ["~> 2.1"])
      s.add_runtime_dependency(%q<cliver>, ["~> 0.3.1"])
      s.add_development_dependency(%q<coffee-script>, ["~> 2.2"])
      s.add_development_dependency(%q<coffee-script-source>, ["~> 1.10.0"])
      s.add_development_dependency(%q<erubis>, [">= 0"])
      s.add_development_dependency(%q<guard-coffeescript>, ["~> 2.0.0"])
      s.add_development_dependency(%q<image_size>, ["~> 1.0"])
      s.add_development_dependency(%q<launchy>, ["~> 2.0"])
      s.add_development_dependency(%q<listen>, ["~> 3.0.6"])
      s.add_development_dependency(%q<pdf-reader>, [">= 1.3.3", "~> 1.3"])
      s.add_development_dependency(%q<rake>, [">= 0"])
      s.add_development_dependency(%q<rspec>, ["~> 3.4.0"])
      s.add_development_dependency(%q<rspec-core>, ["!= 3.4.0"])
      s.add_development_dependency(%q<sinatra>, ["~> 1.0"])
      s.add_runtime_dependency(%q<websocket-driver>, [">= 0.2.0"])
    else
      s.add_dependency(%q<capybara>, ["~> 2.1"])
      s.add_dependency(%q<cliver>, ["~> 0.3.1"])
      s.add_dependency(%q<coffee-script>, ["~> 2.2"])
      s.add_dependency(%q<coffee-script-source>, ["~> 1.10.0"])
      s.add_dependency(%q<erubis>, [">= 0"])
      s.add_dependency(%q<guard-coffeescript>, ["~> 2.0.0"])
      s.add_dependency(%q<image_size>, ["~> 1.0"])
      s.add_dependency(%q<launchy>, ["~> 2.0"])
      s.add_dependency(%q<listen>, ["~> 3.0.6"])
      s.add_dependency(%q<pdf-reader>, [">= 1.3.3", "~> 1.3"])
      s.add_dependency(%q<rake>, [">= 0"])
      s.add_dependency(%q<rspec>, ["~> 3.4.0"])
      s.add_dependency(%q<rspec-core>, ["!= 3.4.0"])
      s.add_dependency(%q<sinatra>, ["~> 1.0"])
      s.add_dependency(%q<websocket-driver>, [">= 0.2.0"])
    end
  else
    s.add_dependency(%q<capybara>, ["~> 2.1"])
    s.add_dependency(%q<cliver>, ["~> 0.3.1"])
    s.add_dependency(%q<coffee-script>, ["~> 2.2"])
    s.add_dependency(%q<coffee-script-source>, ["~> 1.10.0"])
    s.add_dependency(%q<erubis>, [">= 0"])
    s.add_dependency(%q<guard-coffeescript>, ["~> 2.0.0"])
    s.add_dependency(%q<image_size>, ["~> 1.0"])
    s.add_dependency(%q<launchy>, ["~> 2.0"])
    s.add_dependency(%q<listen>, ["~> 3.0.6"])
    s.add_dependency(%q<pdf-reader>, [">= 1.3.3", "~> 1.3"])
    s.add_dependency(%q<rake>, [">= 0"])
    s.add_dependency(%q<rspec>, ["~> 3.4.0"])
    s.add_dependency(%q<rspec-core>, ["!= 3.4.0"])
    s.add_dependency(%q<sinatra>, ["~> 1.0"])
    s.add_dependency(%q<websocket-driver>, [">= 0.2.0"])
  end
end