File: metadata.yml

package info (click to toggle)
ruby-prawn-table 0.2.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, buster, sid, stretch
  • size: 528 kB
  • ctags: 227
  • sloc: ruby: 3,355; makefile: 5
file content (234 lines) | stat: -rw-r--r-- 5,775 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
--- !ruby/object:Gem::Specification
name: prawn-table
version: !ruby/object:Gem::Version
  version: 0.2.2
platform: ruby
authors:
- Gregory Brown
- Brad Ediger
- Daniel Nelson
- Jonathan Greenberg
- James Healy
- Hartwig Brandl
autorequire: 
bindir: bin
cert_chain: []
date: 2015-07-16 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: prawn
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 1.3.0
    - - "<"
      - !ruby/object:Gem::Version
        version: 3.0.0
  type: :runtime
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 1.3.0
    - - "<"
      - !ruby/object:Gem::Version
        version: 3.0.0
- !ruby/object:Gem::Dependency
  name: pdf-inspector
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: 1.1.0
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: 1.1.0
- !ruby/object:Gem::Dependency
  name: yard
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: rspec
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '='
      - !ruby/object:Gem::Version
        version: 2.14.1
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '='
      - !ruby/object:Gem::Version
        version: 2.14.1
- !ruby/object:Gem::Dependency
  name: mocha
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: rake
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: simplecov
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: prawn-manual_builder
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 0.2.0
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - ">="
      - !ruby/object:Gem::Version
        version: 0.2.0
- !ruby/object:Gem::Dependency
  name: pdf-reader
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: '1.2'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - "~>"
      - !ruby/object:Gem::Version
        version: '1.2'
description: |2
    Prawn::Table provides tables for the Prawn PDF toolkit
email:
- gregory.t.brown@gmail.com
- brad@bradediger.com
- dnelson@bluejade.com
- greenberg@entryway.net
- jimmy@deefa.com
- mail@hartwigbrandl.at
executables: []
extensions: []
extra_rdoc_files: []
files:
- COPYING
- GPLv2
- GPLv3
- Gemfile
- LICENSE
- lib/prawn/table.rb
- lib/prawn/table/cell.rb
- lib/prawn/table/cell/image.rb
- lib/prawn/table/cell/in_table.rb
- lib/prawn/table/cell/span_dummy.rb
- lib/prawn/table/cell/subtable.rb
- lib/prawn/table/cell/text.rb
- lib/prawn/table/cells.rb
- lib/prawn/table/column_width_calculator.rb
- lib/prawn/table/version.rb
- manual/contents.rb
- manual/example_helper.rb
- manual/table/basic_block.rb
- manual/table/before_rendering_page.rb
- manual/table/cell_border_lines.rb
- manual/table/cell_borders_and_bg.rb
- manual/table/cell_dimensions.rb
- manual/table/cell_text.rb
- manual/table/column_widths.rb
- manual/table/content_and_subtables.rb
- manual/table/creation.rb
- manual/table/filtering.rb
- manual/table/flow_and_header.rb
- manual/table/image_cells.rb
- manual/table/position.rb
- manual/table/row_colors.rb
- manual/table/span.rb
- manual/table/style.rb
- manual/table/table.rb
- manual/table/width.rb
- prawn-table.gemspec
- spec/cell_spec.rb
- spec/extensions/encoding_helpers.rb
- spec/extensions/mocha.rb
- spec/spec_helper.rb
- spec/table/span_dummy_spec.rb
- spec/table_spec.rb
homepage: https://github.com/prawnpdf/prawn-table
licenses:
- RUBY
- GPL-2
- GPL-3
metadata: {}
post_install_message: 
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - ">="
    - !ruby/object:Gem::Version
      version: 1.9.3
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - ">="
    - !ruby/object:Gem::Version
      version: 1.3.6
requirements: []
rubyforge_project: prawn
rubygems_version: 2.4.5
signing_key: 
specification_version: 4
summary: Provides tables for PrawnPDF
test_files:
- spec/cell_spec.rb
- spec/table_spec.rb
has_rdoc: