File: premailer-rails.gemspec

package info (click to toggle)
ruby-premailer-rails 1.9.7-1
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 320 kB
  • ctags: 116
  • sloc: ruby: 1,073; makefile: 13
file content (28 lines) | stat: -rw-r--r-- 1,154 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
require "premailer/rails/version"

Gem::Specification.new do |s|
  s.name        = "premailer-rails"
  s.version     = Premailer::Rails::VERSION
  s.platform    = Gem::Platform::RUBY
  s.license     = 'MIT'
  s.authors     = ["Philipe Fatio"]
  s.email       = ["philipe.fatio@gmail.com"]
  s.homepage    = "https://github.com/fphilipe/premailer-rails"
  s.summary     = %q{Easily create styled HTML emails in Rails.}
  s.description = %q{This gem brings you the power of the premailer gem to Rails
                     without any configuration needs. Create HTML emails,
                     include a CSS file as you do in a normal HTML document and
                     premailer will inline the included CSS.}

  s.require_paths = ["lib"]

  s.add_dependency 'premailer', '~> 1.7', '>= 1.7.9'
  s.add_dependency 'actionmailer', '>= 3', '< 6'

  s.add_development_dependency 'rspec', '~> 3.3'
  s.add_development_dependency 'nokogiri'
  s.add_development_dependency 'hpricot' unless RUBY_PLATFORM == 'java'
  s.add_development_dependency 'coveralls' if RUBY_ENGINE == 'ruby'
end