File: changelog

package info (click to toggle)
ruby-puppet-forge 3.0.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,172 kB
  • sloc: ruby: 2,113; makefile: 9
file content (139 lines) | stat: -rw-r--r-- 4,488 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
ruby-puppet-forge (3.0.0-1) unstable; urgency=medium

  [ Utkarsh Gupta ]
  * Tighten dependency on ruby-faraday*.

  [ Sebastien Badia ]
  * New upstream version 3.0.0, fix for ruby-faraday* > 1.x (Closes: #976270)
  * d/upstream: Fix missing-bug-tracking
  * d/patches: Refresh patchs, and add DEP-3 headers
    + Bump debhelper compat to 13
    + Bump Standards-Versions to 4.5.1 (no changes)

 -- Sebastien Badia <sbadia@debian.org>  Fri, 29 Jan 2021 00:13:44 +0100

ruby-puppet-forge (2.3.2-1) unstable; urgency=medium

  * Added GitLab CI
  * d/control:
    + Bump Standards-Version to 4.5.0 (no changes needed)
    + Drop compat file, rely on debhelper-compat and bump compat level to 12
    + Add Rules-Requires-Root: no
  * New upstream version 2.3.2
  * d/patches: Refresh Debian patchs

 -- Sebastien Badia <sbadia@debian.org>  Fri, 07 Feb 2020 18:02:12 +0100

ruby-puppet-forge (2.2.9-3) unstable; urgency=medium

  [ Pirate Praveen ]
  * Relax dependency on ruby-faraday (Closes: #923782)

  [ Sebastien Badia ]
  * Move debian/watch to gemwatch.debian.net

 -- Sebastien Badia <sbadia@debian.org>  Thu, 14 Mar 2019 17:49:42 +0100

ruby-puppet-forge (2.2.9-2) unstable; urgency=medium

  * d/upstream: Added Upstream metadata
  * d/compat: Bump compat version to 11
  * d/control:
    + Bump to Standards-Version 4.1.3 (no changes needed)
    + Use salsa.debian.org in Vcs-* fields
  * d/copyright: Update copyritght years and use HTTPS for URI

 -- Sebastien Badia <sbadia@debian.org>  Tue, 13 Mar 2018 19:50:38 +0100

ruby-puppet-forge (2.2.9-1) unstable; urgency=medium

  * New upstream version 2.2.9
  * d/control: Bump to Standards-Version 4.1.2 (no changes needed)
  * d/patches: Refresh 002_loosen_deps.patch (partially applied upstream)
  * d/watch: Use a secure URI for watchfile

 -- Sebastien Badia <sbadia@debian.org>  Thu, 14 Dec 2017 17:00:09 +0100

ruby-puppet-forge (2.2.7-2) unstable; urgency=medium

  * d/patches: Refresh loosen_deps patch, relax faraday (Closes: #869908)

 -- Sebastien Badia <sbadia@debian.org>  Sat, 19 Aug 2017 16:15:25 +0200

ruby-puppet-forge (2.2.7-1) unstable; urgency=medium

  * New upstream version 2.2.7
  * d/patches: Refresh patches according new upstream
  * d/control: Bump Standard-Version to 4.0.0 (no changes needed)

 -- Sebastien Badia <sbadia@debian.org>  Thu, 13 Jul 2017 20:09:29 +0200

ruby-puppet-forge (2.2.4-1) unstable; urgency=medium

  * New upstream version 2.2.4
  * d/control:
    + Bump debhelper compat. to 10
    + Use my Debian email
  * d/patches:
    + Refresh patchs
    + Build puppet-forge with the new semantic and gettext-setup gems
      (Closes: #864566)

 -- Sebastien Badia <sbadia@debian.org>  Fri, 09 Jun 2017 01:02:36 +0200

ruby-puppet-forge (2.2.2-2) unstable; urgency=high

  * [d7b1876] Fix locale loading for vendor_ruby installation (Closes: #832118)

 -- Markus Frosch <lazyfrosch@debian.org>  Thu, 28 Jul 2016 14:52:22 +0200

ruby-puppet-forge (2.2.2-1) unstable; urgency=medium

  [ Sebastien Badia ]
  * Imported Upstream version 2.2.2
  * d/control: Bump Standards version to 3.9.8 (no changes)
  * d/control: Added ruby-gettext-setup (new build/run dependency)

  [ Markus Frosch ]

 -- Sebastien Badia <seb@sebian.fr>  Mon, 18 Jul 2016 17:06:49 +0200

ruby-puppet-forge (2.1.5-1) unstable; urgency=medium

  [ Sebastien Badia ]
  * [8e13d1c] d/control: Bump Standards-Version to 3.9.7 (no changes)

  [ Markus Frosch ]
  * [c8ec513] Imported Upstream version 2.1.5

 -- Markus Frosch <lazyfrosch@debian.org>  Tue, 19 Apr 2016 21:51:17 +0200

ruby-puppet-forge (2.1.3-1) unstable; urgency=medium

  * [41f65eb] Imported Upstream version 2.1.3
  * [cbdd0b5] Update VCS URL
  * [e6258dc] Cleanup depends

 -- Markus Frosch <lazyfrosch@debian.org>  Sun, 07 Feb 2016 13:24:54 +0100

ruby-puppet-forge (2.1.2-1) unstable; urgency=medium

  * [698d738] Imported Upstream version 2.1.2
  * [7513a27] Remove patch allow_newer_faraday

 -- Markus Frosch <lazyfrosch@debian.org>  Fri, 15 Jan 2016 19:43:14 +0100

ruby-puppet-forge (2.1.1-1) unstable; urgency=medium

  [ Sebastien Badia ]
  * Initial release (Closes: #808098)

  [ Markus Frosch ]
  * [5fccd30] Soften up dependency on faraday_middleware
  * [0f9b2d0] Add myself to uploaders
  * [bd4197a] Depend on ruby-minitar
  * [ba07181] Disable network based rspec tests
  * [de01622] Change comment on disabled tests
  * [4eb7cb0] Update description

 -- Markus Frosch <lazyfrosch@debian.org>  Thu, 17 Dec 2015 14:46:20 +0100