File: pygments.rb.gemspec

package info (click to toggle)
ruby-pygments.rb 1.2.0-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 5,420 kB
  • sloc: python: 69,727; ansic: 4,187; ruby: 617; makefile: 181; sh: 120
file content (29 lines) | stat: -rw-r--r-- 850 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
version_file = File.expand_path('../lib/pygments/version.rb', __FILE__)
if not File.exists?(version_file)
  version_file = 'pygments/version'
end
require version_file

Gem::Specification.new do |s|
  s.name = 'pygments.rb'
  s.version = Pygments::VERSION

  s.summary = 'pygments wrapper for ruby'
  s.description = 'pygments.rb exposes the pygments syntax highlighter to Ruby'

  s.homepage = 'https://github.com/tmm1/pygments.rb'
  s.has_rdoc = false

  s.authors = ['Aman Gupta', 'Ted Nyman']
  s.email = ['aman@tmm1.net']
  s.license = 'MIT'

  s.add_dependency 'multi_json', '>= 1.0.0'
  s.add_development_dependency 'rake-compiler', '~> 0.7.6'
  s.add_development_dependency 'test-unit', '~> 3.0.0'

  # s.extensions = ['ext/extconf.rb']
  s.require_paths = ['lib']

  #s.files = `git ls-files`.split("\n").select { |f| !File.symlink?(f) }
end