File: rails-assets-punycode.rb

package info (click to toggle)
ruby-rails-assets-punycode 1.3.2-2.1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 132 kB
  • sloc: javascript: 292; ruby: 36; makefile: 2
file content (47 lines) | stat: -rw-r--r-- 772 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
require "rails-assets-punycode/version"


module RailsAssetsPunycode

  def self.gem_path
    Pathname(__FILE__).join('../..')
  end

  def self.gem_spec
    Gem::Specification::load(
      gem_path.join("rails-assets-punycode.gemspec").to_s
    )
  end

  def self.load_paths
    gem_path.join('app/assets').each_child.to_a
  end

  def self.dependencies
    [
      
    ]
  end

  if defined?(Rails)
    class Engine < ::Rails::Engine
      config.root = '/usr/share/ruby-rails-assets-punycode'
      # Rails -> use app/assets directory.
    end
  end

end

class RailsAssets
  @components ||= []

  class << self
    attr_accessor :components

    def load_paths
      components.flat_map(&:load_paths)
    end
  end
end

RailsAssets.components << RailsAssetsPunycode