1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
From: Alessandro Ghedini <ghedo@debian.org>
Date: Thu, 8 Aug 2024 23:09:06 -0300
Subject: Use system libmarkdown
Origin: vendor
Bug-Debian: https://bugs.debian.org/649489
Forwarded: not-needed
Last-Update: 2014-04-12
Rakefile | 2 +-
ext/extconf.rb | 2 ++
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/Rakefile b/Rakefile
index 4ce58c3..1e32bc2 100644
@@ -17,7 +17,7 @@ file "ext/ruby-#{RUBYDIGEST}" do |f|
end
CLEAN.include "ext/ruby-*"
-file 'ext/Makefile' => FileList['ext/*.{c,h,rb}', "ext/ruby-#{RUBYDIGEST}"] do
+file 'ext/Makefile' => FileList['ext/*.rb', 'ext/rdiscount.c', "ext/ruby-#{RUBYDIGEST}"] do
chdir('ext') { ruby 'extconf.rb' }
end
CLEAN.include 'ext/Makefile', 'ext/mkmf.log'
diff --git a/ext/extconf.rb b/ext/extconf.rb
index 442eef7..09f23ba 100644
@@ -2,6 +2,8 @@ require 'mkmf'
dir_config('rdiscount')
+have_library('markdown')
+
HAVE_RANDOM = have_func('random')
HAVE_SRANDOM = have_func('srandom')
HAVE_RAND = have_func('rand')
|