File: Gemfile

package info (click to toggle)
ruby-rspec-collection-matchers 1.1.2-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid, stretch
  • size: 176 kB
  • ctags: 77
  • sloc: ruby: 919; sh: 7; makefile: 2
file content (47 lines) | stat: -rw-r--r-- 1,272 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
source 'https://rubygems.org'

gemspec

%w[rspec rspec-core rspec-expectations rspec-mocks].each do |lib|
  library_path = File.expand_path("../../#{lib}", __FILE__)
  if File.exist?(library_path)
    gem lib, :path => library_path
  else
    gem lib, :git    => "git://github.com/rspec/#{lib}.git",
             :branch => ENV.fetch('BRANCH',"master")
  end
end

# only the master branch is supported on rspec-support
gem "rspec-support", :git => "git://github.com/rspec/rspec-support.git"

gem "cucumber", "~> 1.1.9"
gem "aruba",    "~> 0.5"
gem "rake",     "~> 10.0.0"

version_file = File.expand_path("../.rails-version", __FILE__)
rails_gem_args = case version = ENV['RAILS_VERSION'] || (File.exist?(version_file) && File.read(version_file).chomp)
when /master/
 { :git => "git://github.com/rails/rails.git" }
when /stable$/
 { :git => "git://github.com/rails/rails.git", :branch => version }
when nil, false, ""
  if RUBY_VERSION < '1.9.3'
    # Rails 4+ requires 1.9.3+, so on earlier versions default to the last 3.x release.
     "3.2.17"
  else
    "4.0.4"
  end
else
  version
end

gem "activesupport", *rails_gem_args
gem "activemodel",   *rails_gem_args


platform :rbx do
  gem 'rubysl'
end

eval File.read('Gemfile-custom') if File.exist?('Gemfile-custom')