File: rspec-its.gemspec

package info (click to toggle)
ruby-rspec-its 1.3.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 148 kB
  • sloc: ruby: 436; sh: 28; makefile: 2
file content (36 lines) | stat: -rw-r--r-- 1,623 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'rspec/its/version'

Gem::Specification.new do |spec|
  spec.name          = "rspec-its"
  spec.version       = RSpec::Its::VERSION
  spec.authors       = ["Peter Alfvin"]
  spec.email         = ["palfvin@gmail.com"]
  spec.description   = %q{RSpec extension gem for attribute matching}
  spec.summary       = %q{Provides "its" method formerly part of rspec-core}
  spec.homepage      = "https://github.com/rspec/rspec-its"
  spec.license       = "MIT"

  spec.metadata = {
    'bug_tracker_uri'   => 'https://github.com/rspec/rspec-its/issues',
    'changelog_uri'     => "https://github.com/rspec/rspec-its/blob/v#{spec.version}/Changelog.md",
    'documentation_uri' => "https://www.rubydoc.info/gems/rspec-its/#{spec.version}",
    'mailing_list_uri'  => 'https://groups.google.com/forum/#!forum/rspec',
    'source_code_uri'   => 'https://github.com/rspec/rspec-its',
  }

  spec.files         = `git ls-files`.split($/) - %w[cucumber.yml]
  spec.executables   = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
  spec.test_files    = spec.files.grep(%r{^(test|spec|features)/})
  spec.require_paths = ["lib"]

  spec.add_runtime_dependency 'rspec-core', '>= 3.0.0'
  spec.add_runtime_dependency 'rspec-expectations', '>= 3.0.0'
  spec.add_development_dependency 'bundler',  '> 1.3.0'
  spec.add_development_dependency 'rake',     '~> 10.1.0'
  spec.add_development_dependency 'cucumber', '~> 1.3.8'
  spec.add_development_dependency "aruba",    "~> 0.6.2" # 0.7 is broken on ruby 1.8.7

end