File: CHANGELOG.md

package info (click to toggle)
ruby-semantic-puppet 1.0.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 288 kB
  • sloc: ruby: 2,860; makefile: 3
file content (42 lines) | stat: -rw-r--r-- 1,451 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
# Change Log
All notable changes to this project will be documented in this file.
This project adheres to [Semantic Versioning](http://semver.org/).

## 1.0.2 - 2018-03-13
- Removed i18n/gettext configuration and string externalization. After further consideration we have decided that
  as a library, semantic_puppet should not be attempting to configure global localization state and the localization
  of error messages etc. is the responsibility of the consuming application.
- Added Appveyor CI configuration

## 1.0.1 - 2017-07-01
- Fix bug causing pre-release identifiers being considered invalid when they contained letters but started with a zero

## 1.0.0 - 2017-04-05
- Complete rewrite of the VersionRange to make it compatible with Node Semver
- General speedup of Version (hash, <=>, and to_s in particular)

## 0.1.4 - 2016-07-06
### Changed
- Externalized all user-facing strings using gettext libraries to support future localization.

## 0.1.3 - 2016-05-24
### Added
- Typesafe implementation of ModuleRelease#eql? (and ModuleRelease#==). (PUP-6341)

## 0.1.2 - 2016-04-29
### Added
- Typesafe implementation of Version#eql? (and Version#==). (PUP-6249)

### Fixed
- Homepage URL in gemspec was incorrect. (fiddyspence)

## 0.1.1 - 2015-04-01
### Added
- license information

### Removed
- template entry from CHANGELOG.md

## 0.1.0 - 2015-03-23
### Added
- initial release in concert with current Puppet Module Tool v4.0.0 behavior