File: metadata.yml

package info (click to toggle)
ruby-serialport 1.3.1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 188 kB
  • ctags: 132
  • sloc: ansic: 1,524; ruby: 72; makefile: 2
file content (114 lines) | stat: -rw-r--r-- 2,592 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
--- !ruby/object:Gem::Specification
name: serialport
version: !ruby/object:Gem::Version
  version: 1.3.1
platform: ruby
authors:
- Guillaume Pierronnet
- Alan Stern
- Daniel E. Shipton
- Tobin Richard
- Hector Parra
- Ryan C. Payne
autorequire: 
bindir: bin
cert_chain: []
date: 2014-07-27 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
  name: bundler
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: rake
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: '0'
- !ruby/object:Gem::Dependency
  name: rake-compiler
  requirement: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: 0.4.1
  type: :development
  prerelease: false
  version_requirements: !ruby/object:Gem::Requirement
    requirements:
    - - '>='
      - !ruby/object:Gem::Version
        version: 0.4.1
description: Ruby/SerialPort is a Ruby library that provides a class for using RS-232
  serial ports.
email: hector@hectorparra.com
executables: []
extensions:
- ext/native/extconf.rb
extra_rdoc_files:
- LICENSE
- README.md
files:
- .gitignore
- .travis.yml
- CHANGELOG
- CHECKLIST
- Gemfile
- LICENSE
- MANIFEST
- README.md
- Rakefile
- ext/native/extconf.rb
- ext/native/posix_serialport_impl.c
- ext/native/serialport.c
- ext/native/serialport.h
- ext/native/win_serialport_impl.c
- lib/serialport.rb
- lib/serialport/version.rb
- serialport.gemspec
- test/miniterm.rb
- test/set_readtimeout.rb
homepage: http://github.com/hparra/ruby-serialport/
licenses:
- GPL-2
metadata: {}
post_install_message: 
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
  requirements:
  - - '>='
    - !ruby/object:Gem::Version
      version: '0'
requirements: []
rubyforge_project: 
rubygems_version: 2.0.14
signing_key: 
specification_version: 4
summary: Library for using RS-232 serial ports.
test_files: []
has_rdoc: