File: Gemfile

package info (click to toggle)
ruby-stringex 2.6.1-1
  • links: PTS, VCS
  • area: main
  • in suites:
  • size: 1,168 kB
  • ctags: 434
  • sloc: ruby: 3,702; makefile: 2
file content (51 lines) | stat: -rw-r--r-- 955 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
# A sample Gemfile
source 'https://rubygems.org'

def activerecord?
  adapter.nil? || adapter == 'activerecord'
end

def datamapper?
  adapter == 'datamapper'
end

def mongoid?
  if RUBY_VERSION > '1.8.x'
    adapter == 'mongoid'
  else
    puts 'Mongoid requires Ruby higher than 1.8.x'
  end
end

def adapter
  ENV['ADAPTER']
end

group :development do
  # Standard gems across gemfiles
  gem 'jeweler', '2.0.1'
  gem 'travis-lint', '1.7.0'
  # Can I state that I really dislike camelcased gem names?
  gem 'RedCloth', '4.2.9'
  gem 'sqlite3', '1.3.10'
  gem 'test-unit', '3.0.9'

  if activerecord?
    gem 'activerecord', '4.0.3'
  end

  if datamapper?
    gem 'dm-core', '1.2.1'
    gem 'dm-migrations', '1.2.0'
    gem 'dm-sqlite-adapter', '1.2.0'
    gem 'dm-validations', '1.2.0'
  end

  if mongoid?
    gem 'mongoid', '3.1.6'
    gem 'i18n', '0.6.1'
  else
    # Everyone else can get the most up-to-date I18n
    gem 'i18n', '0.6.9'
  end
end