File: uber.gemspec

package info (click to toggle)
ruby-uber 0.1.0-1.1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 188 kB
  • sloc: ruby: 466; makefile: 3
file content (21 lines) | stat: -rw-r--r-- 810 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
# -*- encoding: utf-8 -*-
require File.expand_path('../lib/uber/version', __FILE__)

Gem::Specification.new do |gem|
  gem.authors       = ["Nick Sutterer"]
  gem.email         = ["apotonick@gmail.com"]
  gem.description   = %q{A gem-authoring framework.}
  gem.summary       = %q{Gem-authoring tools like generic builders, dynamic options and more.}
  gem.homepage      = "https://github.com/apotonick/uber"
  gem.license       = "MIT"

  gem.files         = `git ls-files`.split($\)
  gem.executables   = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
  gem.test_files    = gem.files.grep(%r{^(test|spec|features)/})
  gem.name          = "uber"
  gem.require_paths = ["lib"]
  gem.version       = Uber::VERSION

  gem.add_development_dependency "rake"
  gem.add_development_dependency "minitest"
end