File: unf_ext.gemspec

package info (click to toggle)
ruby-unf-ext 0.0.7.6-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 5,468 kB
  • sloc: cpp: 14,118; lisp: 1,180; ruby: 94; makefile: 4
file content (42 lines) | stat: -rw-r--r-- 2,195 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
# -*- encoding: utf-8 -*-
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'unf_ext/version'

Gem::Specification.new do |gem|
  gem.name          = "unf_ext"
  gem.version       = UNF::Normalizer::VERSION
  gem.authors       = ["Takeru Ohta", "Akinori MUSHA"]
  gem.email         = ["knu@idaemons.org"]
  gem.description   = %q{Unicode Normalization Form support library for CRuby}
  gem.summary       = %q{Unicode Normalization Form support library for CRuby}
  gem.homepage      = "https://github.com/knu/ruby-unf_ext"
  gem.licenses      = ["MIT"]

  gem.files         = [".document", ".gitignore", ".travis.yml", "CHANGELOG.md", "Gemfile", "LICENSE.txt", "README.md", "Rakefile", "ext/unf_ext/extconf.rb", "ext/unf_ext/unf.cc", "ext/unf_ext/unf/normalizer.hh", "ext/unf_ext/unf/table.hh", "ext/unf_ext/unf/trie/char_stream.hh", "ext/unf_ext/unf/trie/node.hh", "ext/unf_ext/unf/trie/searcher.hh", "ext/unf_ext/unf/util.hh", "lib/unf_ext.rb", "lib/unf_ext/version.rb", "metadata.yml", "test/helper.rb", "test/normalization-test.txt", "test/test_unf_ext.rb", "unf_ext.gemspec"]
  gem.executables   = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
  gem.test_files    = gem.files.grep(%r{^(test|spec|features)/}).grep(%r{/test_[^/]+\.rb$})
  gem.require_paths = ["lib"]
  gem.extensions    = ["ext/unf_ext/extconf.rb"]

  gem.extra_rdoc_files = [
    "LICENSE.txt",
    "README.md"
  ]

  if RUBY_VERSION < "1.9"
    gem.add_development_dependency("rake", [">= 0.9.2.2", "< 11"])
    gem.add_development_dependency('i18n', '< 0.7.0')
    # Cap dependency on activesupport with < 4.0 on behalf of
    # shoulda-matchers to satisfy bundler.
    gem.add_development_dependency("activesupport", ["< 4.0"])
    gem.add_development_dependency("test-unit", ["= 3.1.5"])
  else
    gem.add_development_dependency("rake", [">= 0.9.2.2"])
    gem.add_development_dependency("test-unit")
  end
  gem.add_development_dependency("rdoc", ["> 2.4.2"])
  gem.add_development_dependency("bundler", [">= 1.2"])
  gem.add_development_dependency("rake-compiler", [">= 0.7.9"])
  gem.add_development_dependency("rake-compiler-dock", ["~> 0.7.0"])
end