File: unparser.gemspec

package info (click to toggle)
ruby-unparser 0.4.7-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 564 kB
  • sloc: ruby: 4,630; makefile: 4
file content (32 lines) | stat: -rw-r--r-- 1,253 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Gem::Specification.new do |gem|
  gem.name        = 'unparser'
  gem.version     = '0.4.7'

  gem.authors     = ['Markus Schirp']
  gem.email       = 'mbj@schirp-dso.com'
  gem.summary     = 'Generate equivalent source for parser gem AST nodes'

  gem.description = gem.summary
  gem.homepage    = 'http://github.com/mbj/unparser'
  gem.license     = 'MIT'

  gem.files            = `git ls-files`.split("\n")
  gem.test_files       = `git ls-files -- {spec,features}/*`.split("\n")
  gem.require_paths    = %w[lib]
  gem.extra_rdoc_files = %w[README.md]
  gem.executables      = %w[unparser]

  gem.add_dependency('abstract_type', '~> 0.0.7')
  gem.add_dependency('adamantium',    '~> 0.2.0')
  gem.add_dependency('equalizer',     '~> 0.0.9')
  gem.add_dependency('diff-lcs',      '~> 1.3')
  gem.add_dependency('concord',       '~> 0.1.5')
  gem.add_dependency('parser',        '>= 2.6.5')
  gem.add_dependency('procto',        '~> 0.0.2')

  gem.add_development_dependency('anima',        '~> 0.3.1')
  gem.add_development_dependency('devtools',     '~> 0.1.23')
  gem.add_development_dependency('morpher',      '~> 0.2.6')
  gem.add_development_dependency('mutant',       '~> 0.9.4')
  gem.add_development_dependency('mutant-rspec', '~> 0.9.4')
end