File: valid_email.gemspec

package info (click to toggle)
ruby-valid-email 0.1.3-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 280 kB
  • sloc: ruby: 561; makefile: 4
file content (34 lines) | stat: -rw-r--r-- 1,247 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
require "valid_email/version"

Gem::Specification.new do |s|
  s.name        = "valid_email"
  s.version     = ValidEmailVersion
  s.authors     = ["Ramihajamalala Hery"]
  s.email       = ["hery@rails-royce.org"]
  s.homepage    = "https://github.com/hallelujah/valid_email"
  s.summary     = %q{ActiveModel Validation for email}
  s.description = %q{ActiveModel Validation for email}
  s.license     = 'MIT'

  s.rubyforge_project = "valid_email"

  s.files         = `git ls-files`.split("\n")
  s.test_files    = `git ls-files -- {test,spec,features}/*`.split("\n")
  s.executables   = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.require_paths = ["lib"]

  # specify any dependencies here; for example:
  s.add_development_dependency "rspec", "~> 2.99"
  s.add_development_dependency "rake", '< 11.0'
  s.add_runtime_dependency "mail", ">= 2.6.1"
  if Gem::Version.new(RUBY_VERSION) <= Gem::Version.new('2.0')
    s.add_runtime_dependency 'mime-types', '<= 2.6.2'
  end
  if Gem::Version.new(RUBY_VERSION) < Gem::Version.new('2.2.2')
    s.add_runtime_dependency "activemodel", '< 5.0.0'
  else
    s.add_runtime_dependency "activemodel"
  end
end