File: changelog

package info (click to toggle)
rubygems-integration 1.11
  • links: PTS, VCS
  • area: main
  • in suites: buster, stretch
  • size: 60 kB
  • ctags: 7
  • sloc: ruby: 60; makefile: 18; sh: 9
file content (128 lines) | stat: -rw-r--r-- 4,563 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
rubygems-integration (1.11) unstable; urgency=medium

  [ Cédric Boutillier ]
  * Use https:// in Vcs-* fields
  * Run wrap-and-sort on packaging files

  [ Christian Hofstaedtler ]
  * Bump Standards-Version to 3.9.8 (no changes needed)
  * Bump debhelper compat level to 10

 -- Christian Hofstaedtler <zeha@debian.org>  Sun, 18 Dec 2016 17:43:10 +0000

rubygems-integration (1.10) unstable; urgency=medium

  * Fix overlay incompatibility starting with Ruby 2.1.
    Thanks to Gustavo Machado Campagnani Gama <nsn.igenesis@gmail.com>
    (Closes: #783972)
  * Stop installing compatibility symlink for ruby2.0

 -- Christian Hofstaedtler <zeha@debian.org>  Sat, 19 Dec 2015 01:47:10 +0000

rubygems-integration (1.9) unstable; urgency=medium

  * Include /usr/lib/$(triplet)/rubygems-integration/$(api_version) in the
    Rubygems path. This might be used in the future to make Ruby packages
    support multiarch.
  * debian/tests/control: run specs against installed package.
  * Add workaround for Ruby 2.2 because gem2deb < 0.18.2 installed
    gemspecs to directories named after the short Ruby version (2.2) instead
    of the API_VERSION (2.2.0). There was already a similar workaround for
    Ruby 2.1, so this should have been fixed a long time ago.

 -- Antonio Terceiro <terceiro@debian.org>  Wed, 17 Jun 2015 19:13:10 -0300

rubygems-integration (1.8) unstable; urgency=medium

  [ Antonio Terceiro ]
  * Improve smoke tests in debian/tests/package-list.
    .
    Test a gem that comes together with the interpreter, one arch:all and one
    arch:any

  [ Christian Hofstaedtler ]
  * Add myself to Uploaders
  * Advise rubygems to load SSL certificates from the ca-certificates
    provided list. (Closes: #689074)

 -- Christian Hofstaedtler <zeha@debian.org>  Fri, 05 Sep 2014 02:37:35 +0200

rubygems-integration (1.7) unstable; urgency=medium

  * Drop dependency on Ruby, since the interpreters now actually depend on
    this package.
  * Add workaround for loading ruby2.1-specific gemspecs from wrong path used
    by gem2deb (Closes: #746470)
    .
    The definitive fix belongs in gem2deb and is making it install the
    gemspecs to the correct place so that rubygems-integration does not have
    to be changed again when the next version comes.

 -- Antonio Terceiro <terceiro@debian.org>  Wed, 30 Apr 2014 10:52:48 -0300

rubygems-integration (1.6) unstable; urgency=medium

  * debian/tests/package-list: make output easier to read. First output the
    list of gems to a file, then grep that file.
  * Drop rdoc workaround for Ruby 1.9
  * Add support for disabling rubygems-integration by setting an environment
    variable DEBIAN_DISABLE_RUBYGEMS_INTEGRATION.

 -- Antonio Terceiro <terceiro@debian.org>  Thu, 10 Apr 2014 16:47:15 -0300

rubygems-integration (1.5) unstable; urgency=medium

  * Add /usr/share/rubygems-integration/all to the gem path.
    This will allow installing a single gemspec for `Architecture: all`
    packages that will work with every interpreter, and won't require a new
    upload when a new interpreter comes along.

 -- Antonio Terceiro <terceiro@debian.org>  Mon, 10 Feb 2014 12:16:17 -0300

rubygems-integration (1.4) unstable; urgency=medium

  [ Christian Hofstaedtler ]
  * Support Ruby 2.0+ "default gems" directory

  [ Antonio Terceiro ]
  * Mark as Multi-Arch: foreign
  * Workaround problem with install path of ruby2.0
  * add autopkgtests

 -- Antonio Terceiro <terceiro@debian.org>  Thu, 16 Jan 2014 18:24:54 +0100

rubygems-integration (1.3) unstable; urgency=medium

  * Team upload.

  [ Antonio Terceiro ]
  * Make it possible interpreter to run tests under

  [ Cédric Boutillier ]
  * Bump Standards-Version to 3.9.5 (no changes needed)
  * Drop rubygems from suggested packages, since shipped by Ruby 1.9+

 -- Cédric Boutillier <boutil@debian.org>  Thu, 16 Jan 2014 16:27:13 +0100

rubygems-integration (1.2) unstable; urgency=low

  [ Cédric Boutillier ]
  * debian/control: remove obsolete DM-Upload-Allowed flag
  * use canonical URI in Vcs-* fields

  [ Christian Hofstaedtler ]
  * Silence warnings caused by overriding methods (Closes: #679688)

 -- Antonio Terceiro <terceiro@debian.org>  Sun, 02 Jun 2013 12:31:00 -0300

rubygems-integration (1.1) unstable; urgency=low

  * Add gemspec for rdoc-3.9.4 which is included with ruby1.9.1

 -- Antonio Terceiro <terceiro@debian.org>  Sat, 30 Jun 2012 08:56:00 -0300

rubygems-integration (1.0) unstable; urgency=low

  * Initial release.

 -- Antonio Terceiro <terceiro@debian.org>  Sun, 24 Jun 2012 17:25:52 -0300