File: control

package info (click to toggle)
rust-barrel 0.6.5-2
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 324 kB
  • sloc: makefile: 4
file content (99 lines) | stat: -rw-r--r-- 3,982 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
Source: rust-barrel
Section: rust
Priority: optional
Build-Depends: debhelper (>= 11),
 dh-cargo (>= 18),
 cargo:native <!nocheck>,
 rustc:native <!nocheck>,
 libstd-rust-dev <!nocheck>
Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Uploaders:
 kpcyrd <git@rxv.cc>,
 Wolfgang Silbermayr <wolfgang@silbermayr.at>
Standards-Version: 4.4.1
Vcs-Git: https://salsa.debian.org/rust-team/debcargo-conf.git [src/barrel]
Vcs-Browser: https://salsa.debian.org/rust-team/debcargo-conf/tree/master/src/barrel
Homepage: https://rust-db.github.io/barrel

Package: librust-barrel-dev
Architecture: any
Multi-Arch: same
Depends:
 ${misc:Depends}
Suggests:
 librust-barrel+diesel-dev (= ${binary:Version}),
 librust-barrel+diesel-rs-dev (= ${binary:Version}),
 librust-barrel+tempfile-dev (= ${binary:Version})
Provides:
 librust-barrel+default-dev (= ${binary:Version}),
 librust-barrel+mysql-dev (= ${binary:Version}),
 librust-barrel+pg-dev (= ${binary:Version}),
 librust-barrel+sqlite3-dev (= ${binary:Version}),
 librust-barrel+unstable-dev (= ${binary:Version}),
 librust-barrel-0-dev (= ${binary:Version}),
 librust-barrel-0+default-dev (= ${binary:Version}),
 librust-barrel-0+mysql-dev (= ${binary:Version}),
 librust-barrel-0+pg-dev (= ${binary:Version}),
 librust-barrel-0+sqlite3-dev (= ${binary:Version}),
 librust-barrel-0+unstable-dev (= ${binary:Version}),
 librust-barrel-0.6-dev (= ${binary:Version}),
 librust-barrel-0.6+default-dev (= ${binary:Version}),
 librust-barrel-0.6+mysql-dev (= ${binary:Version}),
 librust-barrel-0.6+pg-dev (= ${binary:Version}),
 librust-barrel-0.6+sqlite3-dev (= ${binary:Version}),
 librust-barrel-0.6+unstable-dev (= ${binary:Version}),
 librust-barrel-0.6.5-dev (= ${binary:Version}),
 librust-barrel-0.6.5+default-dev (= ${binary:Version}),
 librust-barrel-0.6.5+mysql-dev (= ${binary:Version}),
 librust-barrel-0.6.5+pg-dev (= ${binary:Version}),
 librust-barrel-0.6.5+sqlite3-dev (= ${binary:Version}),
 librust-barrel-0.6.5+unstable-dev (= ${binary:Version})
Description: Powerful schema migration building API for Rust - Rust source code
 This package contains the source for the Rust barrel crate, packaged by
 debcargo for use with cargo and dh-cargo.

Package: librust-barrel+diesel-dev
Architecture: any
Multi-Arch: same
Depends:
 ${misc:Depends},
 librust-barrel-dev (= ${binary:Version}),
 librust-diesel-1-dev (>= 1.2-~~),
 librust-tempfile-3+default-dev
Provides:
 librust-barrel-0+diesel-dev (= ${binary:Version}),
 librust-barrel-0.6+diesel-dev (= ${binary:Version}),
 librust-barrel-0.6.5+diesel-dev (= ${binary:Version})
Description: Powerful schema migration building API for Rust - feature "diesel"
 This metapackage enables feature "diesel" for the Rust barrel crate, by pulling
 in any additional dependencies needed by that feature.

Package: librust-barrel+diesel-rs-dev
Architecture: any
Multi-Arch: same
Depends:
 ${misc:Depends},
 librust-barrel-dev (= ${binary:Version}),
 librust-diesel-1-dev (>= 1.2-~~)
Provides:
 librust-barrel-0+diesel-rs-dev (= ${binary:Version}),
 librust-barrel-0.6+diesel-rs-dev (= ${binary:Version}),
 librust-barrel-0.6.5+diesel-rs-dev (= ${binary:Version})
Description: Powerful schema migration building API for Rust - feature "diesel_rs"
 This metapackage enables feature "diesel_rs" for the Rust barrel crate, by
 pulling in any additional dependencies needed by that feature.

Package: librust-barrel+tempfile-dev
Architecture: any
Multi-Arch: same
Depends:
 ${misc:Depends},
 librust-barrel-dev (= ${binary:Version}),
 librust-tempfile-3+default-dev
Provides:
 librust-barrel-0+tempfile-dev (= ${binary:Version}),
 librust-barrel-0.6+tempfile-dev (= ${binary:Version}),
 librust-barrel-0.6.5+tempfile-dev (= ${binary:Version})
Description: Powerful schema migration building API for Rust - feature "tempfile"
 This metapackage enables feature "tempfile" for the Rust barrel crate, by
 pulling in any additional dependencies needed by that feature.