1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117
|
Source: rust-cbindgen
Section: utils
Priority: optional
Build-Depends: debhelper (>= 12),
dh-cargo (>= 17),
cargo:native,
rustc-mozilla:native,
libstd-rust-mozilla-dev,
# librust-clap-3+default-dev (>= 3.1-~~),
# librust-heck-0.4+default-dev,
# librust-indexmap-1+default-dev,
# librust-log-0.4+default-dev,
# librust-proc-macro2-1+default-dev,
# librust-quote-1+default-dev,
# librust-serde-1+derive-dev (>= 1.0.103-~~),
# librust-serde-json-1+default-dev,
# librust-syn-1+clone-impls-dev (>= 1.0.88-~~),
# librust-syn-1+extra-traits-dev (>= 1.0.88-~~),
# librust-syn-1+full-dev (>= 1.0.88-~~),
# librust-syn-1+parsing-dev (>= 1.0.88-~~),
# librust-syn-1+printing-dev (>= 1.0.88-~~),
# librust-tempfile-3+default-dev,
# librust-toml-0.5+default-dev,
help2man,
# librust-serial-test-dev,
cython3
Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Uploaders:
Sylvestre Ledru <sylvestre@debian.org>
Standards-Version: 4.6.1
Vcs-Git: https://salsa.debian.org/rust-team/debcargo-conf.git [src/cbindgen]
Vcs-Browser: https://salsa.debian.org/rust-team/debcargo-conf/tree/master/src/cbindgen
X-Cargo-Crate: cbindgen
Rules-Requires-Root: no
#Package: librust-cbindgen-dev
#Architecture: any
#Multi-Arch: same
#Depends:
# ${misc:Depends},
# librust-heck-0.4+default-dev,
# librust-indexmap-1+default-dev,
# librust-log-0.4+default-dev,
# librust-proc-macro2-1+default-dev,
# librust-quote-1+default-dev,
# librust-serde-1+derive-dev (>= 1.0.103-~~),
# librust-serde-json-1+default-dev,
# librust-syn-1+clone-impls-dev (>= 1.0.88-~~),
# librust-syn-1+extra-traits-dev (>= 1.0.88-~~),
# librust-syn-1+full-dev (>= 1.0.88-~~),
# librust-syn-1+parsing-dev (>= 1.0.88-~~),
# librust-syn-1+printing-dev (>= 1.0.88-~~),
# librust-tempfile-3+default-dev,
# librust-toml-0.5+default-dev
#Recommends:
# librust-cbindgen+clap-dev (= ${binary:Version})
#Provides:
# librust-cbindgen-0-dev (= ${binary:Version}),
# librust-cbindgen-0.24-dev (= ${binary:Version}),
# librust-cbindgen-0.24.3-dev (= ${binary:Version})
#Description: Generating C bindings to Rust code - Rust source code
# This package contains the source for the Rust cbindgen crate, packaged by
# debcargo for use with cargo and dh-cargo.
#
#Package: librust-cbindgen+clap-dev
#Architecture: any
#Multi-Arch: same
#Depends:
# ${misc:Depends},
# librust-cbindgen-dev (= ${binary:Version}),
# librust-clap-3+default-dev (>= 3.1-~~)
#Provides:
# librust-cbindgen+default-dev (= ${binary:Version}),
# librust-cbindgen-0+clap-dev (= ${binary:Version}),
# librust-cbindgen-0+default-dev (= ${binary:Version}),
# librust-cbindgen-0.24+clap-dev (= ${binary:Version}),
# librust-cbindgen-0.24+default-dev (= ${binary:Version}),
# librust-cbindgen-0.24.3+clap-dev (= ${binary:Version}),
# librust-cbindgen-0.24.3+default-dev (= ${binary:Version})
#Description: Generating C bindings to Rust code - feature "clap" and 1 more
# This metapackage enables feature "clap" for the Rust cbindgen crate, by pulling
# in any additional dependencies needed by that feature.
# .
# Additionally, this package also provides the "default" feature.
Package: cbindgen
Architecture: any
Multi-Arch: allowed
Section: utils
Depends:
${misc:Depends},
${shlibs:Depends},
${cargo:Depends}
Recommends:
${cargo:Recommends}
Suggests:
${cargo:Suggests}
Provides:
${cargo:Provides}
Built-Using: ${cargo:Built-Using}
XB-X-Cargo-Built-Using: ${cargo:X-Cargo-Built-Using}
Description: Generates C bindings from Rust code
cbindgen can be used to generate C bindings for Rust code.
It is currently being developed to support creating bindings for
WebRender (by Mozilla for Firefox), but has been designed to support
any project.
.
Features:
.
* Builds bindings for a crate, its mods, its dependent crates, and their mods
* Only the necessary types for exposed functions are given bindings
* Can specify annotations for controlling some aspects of binding
* Support for generic structs and unions
* Support for exporting constants and statics
* Customizable formatting, can be used in C or C++ projects
* Support for generating #ifdef's for #[cfg] attributes
* Support for #[repr(sized)] tagged enum's
|