File: Cargo.toml

package info (click to toggle)
rust-grep-searcher 0.1.7-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 364 kB
  • sloc: makefile: 6
file content (55 lines) | stat: -rw-r--r-- 1,570 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
#
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
# to registry (e.g., crates.io) dependencies
#
# If you believe there's an error in this file please file an
# issue against the rust-lang/cargo repository. If you're
# editing this file be aware that the upstream Cargo.toml
# will likely look very different (and much more reasonable)

[package]
name = "grep-searcher"
version = "0.1.7"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
description = "Fast line oriented regex searching as a library.\n"
homepage = "https://github.com/BurntSushi/ripgrep/tree/master/crates/searcher"
documentation = "https://docs.rs/grep-searcher"
readme = "README.md"
keywords = ["regex", "grep", "egrep", "search", "pattern"]
license = "Unlicense/MIT"
repository = "https://github.com/BurntSushi/ripgrep/tree/master/crates/searcher"
[dependencies.bstr]
version = "0.2.0"
features = ["std"]
default-features = false

[dependencies.bytecount]
version = "0.6"

[dependencies.encoding_rs]
version = "0.8.14"

[dependencies.encoding_rs_io]
version = "0.1.6"

[dependencies.grep-matcher]
version = "0.1.2"

[dependencies.log]
version = "0.4.5"

[dependencies.memmap]
version = ">= 0.6.2, < 0.8"
[dev-dependencies.grep-regex]
version = "0.1.3"

[dev-dependencies.regex]
version = ">= 1.0.5"

[features]
avx-accel = []
default = ["bytecount/runtime-dispatch-simd"]
simd-accel = ["encoding_rs/simd-accel"]