File: Cargo.toml

package info (click to toggle)
rust-gtk 0.5.0-2
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 3,792 kB
  • sloc: makefile: 20; sh: 17
file content (112 lines) | stat: -rw-r--r-- 2,855 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
#
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
# to registry (e.g. crates.io) dependencies
#
# If you believe there's an error in this file please file an
# issue against the rust-lang/cargo repository. If you're
# editing this file be aware that the upstream Cargo.toml
# will likely look very different (and much more reasonable)

[package]
name = "gtk"
version = "0.5.0"
authors = ["The Gtk-rs Project Developers"]
build = "build.rs"
exclude = ["gir-files/*"]
description = "Rust bindings for the GTK+ 3 library"
homepage = "http://gtk-rs.org/"
documentation = "http://gtk-rs.org/docs/gtk/"
readme = "README.md"
keywords = ["gtk", "gtk-rs", "gnome", "GUI"]
categories = ["api-bindings", "gui"]
license = "MIT"
repository = "https://github.com/gtk-rs/gtk"

[lib]
name = "gtk"
[dependencies.bitflags]
version = "1.0"

[dependencies.cairo-rs]
version = "0.5.0"

[dependencies.cairo-sys-rs]
version = "0.7.0"

[dependencies.fragile]
version = "0.3"
optional = true

[dependencies.gdk]
version = "0.9.0"

[dependencies.gdk-pixbuf]
version = "0.5.0"

[dependencies.gdk-pixbuf-sys]
version = "0.7.0"

[dependencies.gdk-sys]
version = "0.7.0"

[dependencies.gio]
version = "0.5.0"

[dependencies.gio-sys]
version = "0.7.0"

[dependencies.glib]
version = "0.6.0"

[dependencies.glib-sys]
version = "0.7.0"

[dependencies.gobject-sys]
version = "0.7.0"

[dependencies.gtk-sys]
version = "0.7.0"

[dependencies.lazy_static]
version = "1.0"

[dependencies.libc]
version = "0.2"

[dependencies.pango]
version = "0.5.0"
[dev-dependencies.gir-format-check]
version = "^0.1"
[build-dependencies.gtk-rs-lgpl-docs]
version = "0.1.3"
optional = true

[features]
dox = ["gdk/dox", "gtk-sys/dox"]
embed-lgpl-docs = ["gtk-rs-lgpl-docs", "gdk/embed-lgpl-docs"]
purge-lgpl-docs = ["gtk-rs-lgpl-docs", "gdk/purge-lgpl-docs"]
v3_10 = ["v3_8", "gtk-sys/v3_10", "gdk/v3_10"]
v3_12 = ["v3_10", "gtk-sys/v3_12", "gdk/v3_12"]
v3_14 = ["v3_12", "gtk-sys/v3_14", "gdk/v3_14"]
v3_16 = ["v3_14", "gtk-sys/v3_16", "gdk/v3_16", "gio/v2_44"]
v3_18 = ["v3_16", "gtk-sys/v3_18", "gdk/v3_18"]
v3_20 = ["v3_18", "gtk-sys/v3_20", "gdk/v3_20"]
v3_22 = ["v3_20", "gtk-sys/v3_22", "gdk/v3_22"]
v3_22_20 = ["v3_22", "gtk-sys/v3_22_26", "gdk/v3_22"]
v3_22_26 = ["v3_22_20", "gtk-sys/v3_22_26", "gdk/v3_22"]
v3_22_27 = ["v3_22_26", "gtk-sys/v3_22_27"]
v3_22_29 = ["v3_22_27", "gtk-sys/v3_22_29"]
v3_22_30 = ["v3_22_29", "gdk/v3_22_30"]
v3_6 = ["gtk-sys/v3_6", "gdk/v3_6"]
v3_8 = ["v3_6", "gtk-sys/v3_8", "gdk/v3_8"]
[target."cfg(target_os = \"macos\")".build-dependencies.cc]
version = "^1.0"
[badges.appveyor]
repository = "GuillaumeGomez/gtk"
service = "github"

[badges.travis-ci]
repository = "gtk-rs/gtk"