1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78
|
%:
dh $@ --buildsystem cargo
execute_before_dh_auto_build:
cp /usr/share/gir-1.0/freetype2-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Gdk-4.0.gir $(CURDIR)
cp /usr/share/gir-1.0/GdkPixbuf-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Gio-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/GLib-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/GModule-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/GObject-2.0.gir $(CURDIR)
cp /usr/share/gir-1.0/HarfBuzz-0.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Pango-1.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Shumate-1.0.gir $(CURDIR)
cp /usr/share/gir-1.0/cairo-1.0.gir $(CURDIR)
cp /usr/share/gir-1.0/PangoCairo-1.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Gsk-4.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Graphene-1.0.gir $(CURDIR)
cp /usr/share/gir-1.0/Gtk-4.0.gir $(CURDIR)
xmlstarlet ed -L \
-d '///_:alias[@name="Int32"]' \
freetype2-2.0.gir
xmlstarlet ed -L \
-i '///_:type[not(@name) and @c:type="hb_font_t*"]' -t 'attr' -n 'name' -v "gconstpointer" \
-u '//_:type[@c:type="hb_font_t*"]/@c:type' -v "gconstpointer" \
-i '///_:array[not(@name) and @c:type="hb_feature_t*"]' -t 'attr' -n 'name' -v "gconstpointer" \
-r '///_:array[@c:type="hb_feature_t*"]' -v "type" \
-d '//_:type[@c:type="hb_feature_t*"]/*' \
-d '//_:type[@c:type="hb_feature_t*"]/@length' \
-d '//_:type[@c:type="hb_feature_t*"]/@zero-terminated' \
-u '//_:type[@c:type="hb_feature_t*"]/@c:type' -v "gconstpointer" \
-d '//_:record[@c:type="PangoGlyphVisAttr"]/_:field/@bits' \
-d '//_:record[@c:type="PangoGlyphVisAttr"]/_:field[@name="is_color"]' \
Pango-1.0.gir
xmlstarlet ed -L \
-u '//*[@glib:error-domain="g-option-context-error-quark"]/@glib:error-domain' -v g-option-error-quark \
-u '//_:record[@name="KeyFile"]/_:method[@name="set_boolean_list"]//_:parameter[@name="list"]/_:array/@c:type' -v "gboolean*" \
-u '//_:record[@name="KeyFile"]/_:method[@name="set_double_list"]//_:parameter[@name="list"]/_:array/@c:type' -v "gdouble*" \
-u '//_:record[@name="KeyFile"]/_:method[@name="set_integer_list"]//_:parameter[@name="list"]/_:array/@c:type' -v "gint*" \
-u '//_:record[@name="KeyFile"]/_:method[@name="set_locale_string_list"]//_:parameter[@name="list"]/_:array/@c:type' -v "const gchar* const*" \
-u '//_:record[@name="KeyFile"]/_:method[@name="set_string_list"]//_:parameter[@name="list"]/_:array/@c:type' -v "const gchar* const*" \
GLib-2.0.gir
xmlstarlet ed -L \
-u '//_:class[@name="Object"]/_:method[@name="getv"]//_:parameter[@name="names"]/_:array/@c:type' -v "const gchar**" \
-u '//_:class[@name="Object"]/_:method[@name="getv"]//_:parameter[@name="values"]/_:array/@c:type' -v "GValue*" \
-u '//_:class[@name="Object"]/_:method[@name="setv"]//_:parameter[@name="names"]/_:array/@c:type' -v "const gchar**" \
-u '//_:class[@name="Object"]/_:method[@name="setv"]//_:parameter[@name="values"]/_:array/@c:type' -v "const GValue*" \
-u '//_:class[@name="Object"]/_:constructor[@name="new_with_properties"]//_:parameter[@name="names"]/_:array/@c:type' -v "const char**" \
-u '//_:class[@name="Object"]/_:constructor[@name="new_with_properties"]//_:parameter[@name="values"]/_:array/@c:type' -v "const GValue*" \
-i '//_:interface[@name="TypePlugin" and not(@glib:type-struct)]' -t 'attr' -n 'glib:type-struct' -v 'TypePluginClass' \
-i '//_:record[@name="TypePluginClass" and not(@glib:is-gtype-struct-for)]' -t 'attr' -n 'glib:is-gtype-struct-for' -v 'TypePlugin' \
GObject-2.0.gir
xmlstarlet ed -L \
-u '//_:record[@name="PixbufModule"]/_:field[@name="module"]/_:type/@name' -v "gpointer" \
-u '//_:record[@name="PixbufModule"]/_:field[@name="module"]/_:type/@c:type' -v "gpointer" \
GdkPixbuf-2.0.gir
xmlstarlet ed -L \
-d '///_:function[@c:identifier="hb_graphite2_face_get_gr_face"]' \
-d '///_:function[@c:identifier="hb_graphite2_font_get_gr_font"]' \
-d '///_:function[@c:identifier="hb_ft_face_create"]' \
-d '///_:function[@c:identifier="hb_ft_face_create_cached"]' \
-d '///_:function[@c:identifier="hb_ft_face_create_referenced"]' \
-d '///_:function[@c:identifier="hb_ft_font_create"]' \
-d '///_:function[@c:identifier="hb_ft_font_create_cached"]' \
-d '///_:function[@c:identifier="hb_ft_font_create_referenced"]' \
-d '///_:function[@c:identifier="hb_ft_font_get_face"]' \
-d '///_:function[@c:identifier="hb_ft_font_lock_face"]' \
HarfBuzz-0.0.gir
sed -i 's/girs_directories\s=\s\[\"\.\.\/gir-files\",\s\"\.\.\/\"\]/girs_directories=\[\".\"\]/' $(CURDIR)/Gir.toml
gir -o .
# Remove the .gir files before install
execute_before_dh_auto_install:
rm $(CURDIR)/*.gir
|