1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Date: Thu, 14 Jul 2022 13:17:37 +0200
Subject: u-ignore-ppc-hangs
Bug: https://github.com/rust-lang/rust/issues/89607
library/alloc/tests/arc.rs | 1 +
library/alloc/tests/rc.rs | 1 +
2 files changed, 2 insertions(+)
diff --git a/library/alloc/tests/arc.rs b/library/alloc/tests/arc.rs
index a259c01..0ac0cbe 100644
@@ -95,6 +95,7 @@ const SHARED_ITER_MAX: u16 = 100;
fn assert_trusted_len<I: TrustedLen>(_: &I) {}
+#[cfg(not(any(target_arch = "powerpc", target_arch = "powerpc64")))]
#[test]
fn shared_from_iter_normal() {
// Exercise the base implementation for non-`TrustedLen` iterators.
diff --git a/library/alloc/tests/rc.rs b/library/alloc/tests/rc.rs
index 451765d..363c29c 100644
@@ -91,6 +91,7 @@ const SHARED_ITER_MAX: u16 = 100;
fn assert_trusted_len<I: TrustedLen>(_: &I) {}
+#[cfg(not(any(target_arch = "powerpc", target_arch = "powerpc64")))]
#[test]
fn shared_from_iter_normal() {
// Exercise the base implementation for non-`TrustedLen` iterators.
|