1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
|
From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Date: Sat, 2 Oct 2021 01:08:00 +0100
Subject: d-0005-no-jemalloc
Description: remove jemalloc-sys
Forwarded: not-needed
compiler/rustc/Cargo.toml | 6 ------
src/tools/rust-analyzer/crates/profile/Cargo.toml | 2 --
src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml | 4 ----
3 files changed, 12 deletions(-)
diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
index d24b630..2256524 100644
@@ -20,14 +20,8 @@ rustc_smir = { path = "../rustc_smir" }
stable_mir = { path = "../stable_mir" }
# tidy-alphabetical-end
-[dependencies.tikv-jemalloc-sys]
-version = "0.6.0"
-optional = true
-features = ['unprefixed_malloc_on_supported_platforms']
-
[features]
# tidy-alphabetical-start
-jemalloc = ['dep:tikv-jemalloc-sys']
llvm = ['rustc_driver_impl/llvm']
max_level_info = ['rustc_driver_impl/max_level_info']
rustc_randomized_layouts = ['rustc_driver_impl/rustc_randomized_layouts']
diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
index 2e3413f..f823aa1 100644
@@ -15,7 +15,6 @@ doctest = false
[dependencies]
cfg-if = "1.0.0"
libc.workspace = true
-jemalloc-ctl = { version = "0.5.0", package = "tikv-jemalloc-ctl", optional = true }
[target.'cfg(target_os = "linux")'.dependencies]
perf-event = "=0.4.7"
@@ -25,7 +24,6 @@ windows-sys = { version = "0.52", features = ["Win32_System_Threading", "Win32_S
[features]
cpu_profiler = []
-jemalloc = ["jemalloc-ctl"]
# Uncomment to enable for the whole crate graph
# default = [ "cpu_profiler" ]
diff --git a/src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml
index fa9ff6b..ba1925d 100644
@@ -78,9 +78,6 @@ paths.workspace = true
[target.'cfg(windows)'.dependencies]
windows-sys = { version = "0.52", features = ["Win32_System_Threading"] }
-[target.'cfg(not(target_env = "msvc"))'.dependencies]
-jemallocator = { version = "0.5.0", package = "tikv-jemallocator", optional = true }
-
[dev-dependencies]
expect-test = "1.4.0"
xshell.workspace = true
@@ -90,7 +87,6 @@ test-fixture.workspace = true
syntax-bridge.workspace = true
[features]
-jemalloc = ["jemallocator", "profile/jemalloc"]
force-always-assert = ["always-assert/force"]
sysroot-abi = []
in-rust-tree = [
|