1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
%:
dh $@ --with gnome
override_dh_auto_configure:
find . -name "*_vala.stamp" | xargs rm -f
dh_auto_configure -- \
--libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--libexecdir=/usr/lib \
--with-systemduserunitdir=/usr/lib/systemd/user \
--enable-mediathek-plugin \
--enable-gst-launch-plugin \
--disable-lms-plugin \
--disable-apidocs
override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_strip:
dh_strip --dbgsym-migration='rygel-dbg (<< 0.28.3-2~)'
override_dh_makeshlibs:
dh_makeshlibs -X /usr/lib/$(DEB_HOST_MULTIARCH)/rygel-2.6/
override_dh_install:
find debian/tmp -name '*.la' -print -delete
dh_install
override_dh_missing:
dh_missing --fail-missing
|