File: changelog

package info (click to toggle)
ryu 4.30+ds1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 24,204 kB
  • sloc: python: 111,247; erlang: 14,517; ansic: 594; sh: 516; makefile: 150
file content (270 lines) | stat: -rw-r--r-- 9,381 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
ryu (4.30+ds1-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

  [ Thomas Goirand ]
  * Uploading to unstable.

 -- Thomas Goirand <zigo@debian.org>  Thu, 18 Jul 2019 23:56:43 +0200

ryu (4.30+ds1-1) experimental; urgency=medium

  * New upstream release.
  * Removed fix-ut-when-running-in-python-3.7-env.patch applied upstream.

 -- Thomas Goirand <zigo@debian.org>  Tue, 26 Mar 2019 15:46:54 +0100

ryu (4.26+dfsg1-5) unstable; urgency=medium

  [ Ondřej Nový ]
  * Running wrap-and-sort -bast.

  [ Thomas Goirand ]
  * Fix Breaks+Replaces to allow upgrade for Stretch (Closes: #917992).

 -- Thomas Goirand <zigo@debian.org>  Thu, 10 Jan 2019 10:30:25 +0100

ryu (4.26+dfsg1-4) unstable; urgency=medium

  * Removed update-alternatives --install /usr/bin/ryu{,-manager}, as we don't
    want it since removal of Python 2 support.

 -- Thomas Goirand <zigo@debian.org>  Tue, 01 Jan 2019 05:59:04 +0100

ryu (4.26+dfsg1-3) unstable; urgency=medium

  * Removed Python 2 support.
  * Add fix-ut-when-running-in-python-3.7-env.patch (Closes: #917661).

 -- Thomas Goirand <zigo@debian.org>  Sun, 30 Dec 2018 06:01:35 +0100

ryu (4.26+dfsg1-2) unstable; urgency=medium

  * Uploading to unstable.

 -- Thomas Goirand <zigo@debian.org>  Mon, 03 Sep 2018 23:44:47 +0200

ryu (4.26+dfsg1-1) experimental; urgency=medium

  [ Ondřej Nový ]
  * d/control: Use team+openstack@tracker.debian.org as maintainer

  [ Thomas Goirand ]
  * New upstream release.
  * Rebased both 2 patches.

 -- Thomas Goirand <zigo@debian.org>  Thu, 23 Aug 2018 13:53:12 +0200

ryu (4.21+dfsg1-4) unstable; urgency=medium

  * Fixed Python 3 shebang.

 -- Thomas Goirand <zigo@debian.org>  Sun, 18 Mar 2018 21:00:30 +0000

ryu (4.21+dfsg1-3) unstable; urgency=medium

  * Uploading to unstable.

 -- Thomas Goirand <zigo@debian.org>  Mon, 26 Feb 2018 00:22:39 +0000

ryu (4.21+dfsg1-2) experimental; urgency=medium

  * Add python-pip and python-tinyrpc as runtime depends.

 -- Thomas Goirand <zigo@debian.org>  Thu, 22 Feb 2018 13:24:39 +0000

ryu (4.21+dfsg1-1) experimental; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * Running wrap-and-sort -bast

  [ Thomas Goirand ]
  * New upstream release.
  * Rebased remove-test-requirements-units.patch.
  * Remove test: test_0_call_bytearray(), failing for an unknown reason.
  * Fixed debian/copyright (removed some files which are gone upstream).

 -- Thomas Goirand <zigo@debian.org>  Fri, 16 Feb 2018 16:48:17 +0000

ryu (4.15+dfsg1-3) unstable; urgency=medium

  * Sets http_proxy=127.0.0.1:9 https_proxy=127.0.0.1:9  when running tests,
    to make sure we don't have network when running tests.
  * Add remove-test-requirements-units.patch to not access network during run
    of unit tests. (Closes: #880863)
  * Removed build-depends on dh-systemd.
  * Removed duplicate build-depends on python-sphinx-rtd-theme.
  * Standards-Version is now 4.1.1.
  * Deprecating priority extra as per policy 4.0.1.
  * Now support <!nocheck> and <!nodoc> build profiles.

 -- Thomas Goirand <zigo@debian.org>  Sun, 05 Nov 2017 13:16:19 +0000

ryu (4.15+dfsg1-2) unstable; urgency=medium

  * Uploading to unstable.

 -- Thomas Goirand <zigo@debian.org>  Thu, 02 Nov 2017 12:52:18 +0000

ryu (4.15+dfsg1-1) experimental; urgency=medium

  [ James Page ]
  * Add python3 support, default ryu-bin to python3:
    - d/p/py3-compat.patch: Python3 compatibility for ovs contrib module.
    - d/control,rules: Add python3-ryu package with alternatives
      configuration for ryu and ryu-manager.
    - d/control: Prefer python3-ryu for ryu-bin package.
  * d/control,ryu-bin.postinst,ryu-bin.ryu.init.in: Run ryu daemon as
    ryu user instead of root.
  * d/python3-ryu.postinst: Prefer Python 3 binaries if both python
    module versions are installed.
  * d/rules: Tidy package clean.

  [ Daniel Baumann ]
  * Updating vcs fields.
  * Updating copyright format url.
  * Updating maintainer field.
  * Running wrap-and-sort -bast.
  * Updating standards version to 4.0.0.
  * Removing gbp.conf, not used anymore or should be specified in the
    developers dotfiles.
  * Correcting permissions in debian packaging files.
  * Updating standards version to 4.0.1.
  * Updating standards version to 4.1.0.

  [ Thomas Goirand ]
  * New upstream release.
  * Test with all versions of Python 3.
  * Fixed priority to extra, as the policy deprecates optional.
  * Rewrote ryu-bin.postinst to use pkgos postinst functions.
  * Removed py3 patches applied upstream.
  * Added python{3,}-{pip,tinyrpc,openvswitch} as build-depends.

 -- Thomas Goirand <zigo@debian.org>  Sun, 15 Oct 2017 10:22:14 +0200

ryu (4.4+dfsg1-1) experimental; urgency=medium

  * New upstream release.
  * Remove ryu/contrib/ovs from debian/copyright (folder is gone).

 -- Thomas Goirand <zigo@debian.org>  Fri, 15 Jul 2016 16:13:52 +0200

ryu (3.30+dfsg1-3) unstable; urgency=medium

  [ Ondřej Nový ]
  * Standards-Version is 3.9.8 now (no change)
  * d/rules: Changed UPSTREAM_GIT protocol to https
  * d/copyright: Changed source URL to https protocol

  [ Thomas Goirand ]
  * Add build-depends-indep on python-sphinx-rtd-theme. (Closes: #829024)

 -- Thomas Goirand <zigo@debian.org>  Thu, 30 Jun 2016 09:58:13 +0200

ryu (3.30+dfsg1-2) unstable; urgency=medium

  * Uploading to unstable.

 -- Thomas Goirand <zigo@debian.org>  Mon, 04 Apr 2016 20:14:30 +0000

ryu (3.30+dfsg1-1) experimental; urgency=medium

  * New upstream release.
  * Uploading to experimental until Mitaka is out.
  * Moved the package to PKG OpenStack:
    - Updated VCS fields.
    - Switched to git tag based workflow instead of pristine-tar (updated
      gbp.conf, etc.).
    - Added build-depends on openstack-pkg-tools.
    - Added export OSLO_PACKAGE_VERSION
    - Added upstream VCS URL in debian/rules.
    - Includes pkgos.make in debian/rules.
    - Now using +dfsg1 suffix from upstream, showing we're removing their
      debian folder. Updated watch file accordingly.
  * Added myself as Uploaders:.
  * Removed useless X-Python-Version: in python-ryu.
  * Added myself in debian/copyright.
  * Added explicit --buildsystem=python_distutils for dh.
  * Switched the ryu.init to ryu.init.in format from openstack-pkg-tools, so
    that ryu supports sysv-rc, upstart and systemd now:
    - rm -f debian/*.init debian/*.upstart debian/*.service in d/rules
    - added --with systemd
    - build-depends on dh-systemd.
    - scraped most of the sysv-rc init script, enriched the declarative part.
    - trashed the debian/*.service unit file, now generated automatically.
  * Added copytruncate in the ryu logrotate file.
  * Standards-Version: 3.9.7 (no change).
  * Removed ryu-bin.dirs, created on daemon startup.
  * Added ryu-bin.postrm to purge /var/log/ryu and /var/lib/ryu on purge.

 -- Thomas Goirand <zigo@debian.org>  Tue, 08 Mar 2016 23:26:51 +0100

ryu (3.26-1) unstable; urgency=medium

  * Imported Upstream version 3.26
  * d/patches: removed patch fixing pbr version in setup.py

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Fri, 02 Oct 2015 14:40:35 +0200

ryu (3.24-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Ran wrap-and-sort -t -a.
  * Fixed wrong location for python-setuptools and python-pbr: they should be
    in Build-Depends and not Build-Depends-Indep as they are needed for clean.
  * Fixed wrong version of pbr in setup.py: the restriction is simply wrong.
  * Removed versions in (build-)depends when already satisfied in Jessie &
    Trusty.
  * Added running of test suite: now build-depends-indep on nose, formencode,
    mock.
  * Make sure dh_clean doesn't download by setting http{s,}_proxy.
  * Drops now useless X-Python-Version: >= 2.6 (Jessie has 2.7 only).
  * Using sphinx-build directly instead of the provided Makefile.
  * Added (= ${binary:Version}) in ryu-bin python-ryu depends:.
  * Added extend-diff-ignore = "^[^/]*[.]egg-info/" in d/s/options, do not
    clean egg-info on clean.
  * Added overrides of dh commands we don't need to run.

 -- Thomas Goirand <zigo@debian.org>  Fri, 25 Sep 2015 10:10:59 +0200

ryu (3.24-1) unstable; urgency=medium

  * Imported Upstream version 3.24 (Closes: #794101)

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Sun, 09 Aug 2015 17:45:44 +0200

ryu (3.23-2) unstable; urgency=medium

  * d/rules: doc build date taken from changelog

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Thu, 30 Jul 2015 20:55:33 +0200

ryu (3.23-1) unstable; urgency=medium

  * Imported Upstream version 3.23

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Thu, 23 Jul 2015 11:27:02 +0200

ryu (3.19-1) unstable; urgency=medium

  * Imported Upstream version 3.19
  * d/control: dh-python added to build deps

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Sun, 22 Mar 2015 19:37:52 +0100

ryu (3.14-1) unstable; urgency=medium

  * Imported Upstream version 3.14
  * Updated path in d/copyright
  * Bump standards to 3.9.6
    - no changes needed

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Wed, 22 Oct 2014 09:37:48 +0200

ryu (3.12-1) unstable; urgency=medium

  * Initial release (Closes: #758509)

 -- Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>  Mon, 18 Aug 2014 16:58:52 +0200