1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
Description: Improve error messages
Improve the error messages of samhain by pointing to the user
how to fix them. For example, the signature database might not
exist because it has not been created yet.
Since these messages are shown in the log and in the output
of systemctl (or journal) they are important as otherwise the
administrator might not have a clue how to fix them
Specially in Debian, where the integrity database might not be
created right after the package configuration (and the service
will fail to start)
Author: Javier Fernández-Sanguino Peña <jfs@debian.org>
Forwarded: not-needed
Last-Update: 2024-10-05
--- a/src/sh_dbIO.c
+++ b/src/sh_dbIO.c
@@ -733,7 +733,7 @@
{
TPT(( 0, FIL__, __LINE__, _("msg=<Error opening: %s>\n"), filepath));
dlog(1, FIL__, __LINE__,
- _("Could not open the local file signature database for reading because\nof the following error: %s (errnum = %ld)\nIf this is a permission problem, you need to change file permissions\nto make the file readable for the effective UID: %d\n"),
+ _("Could not open the local file signature database for reading because\nof the following error: %s (errnum = %ld)\nIf this is a permission problem, you need to change file permissions\nto make the file readable for the effective UID: %d\nIf the file does not exist, initialize the database running 'samhain -t init' as root\n"),
sl_get_errmsg(), fd, (int) sl_ret_euid());
sh_error_handle ((-1), FIL__, __LINE__, fd, MSG_EXIT_ABORT1,
sh.prg_name);
--- a/src/sh_readconf.c
+++ b/src/sh_readconf.c
@@ -431,7 +431,7 @@
{
sl_get_euid(&euid);
dlog(1, FIL__, __LINE__,
- _("Could not open the local configuration file for reading because\nof the following error: %s (errnum = %ld)\nIf this is a permission problem, you need to change file permissions\nto make the file readable for the effective UID: %d\n"),
+ _("Could not open the local configuration file for reading because\nof the following error: %s (errnum = %ld)\nIf this is a permission problem, you need to change file permissions\nto make the file readable for the effective UID: %d\nIf the file does not exist, make sure to create one. You can use the examples provided with this software as a starting point\n"),
sl_get_errmsg(), fd, (int) euid);
sh_error_handle ((-1), FIL__, __LINE__, fd, MSG_NOACCESS,
(long) euid,
|