File: changelog

package info (click to toggle)
sasmodels 0.99-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 14,760 kB
  • sloc: python: 22,292; ansic: 6,140; makefile: 149; sh: 91
file content (68 lines) | stat: -rw-r--r-- 2,333 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
sasmodels (0.99-2) unstable; urgency=medium

  * mark python-sasmodels-doc as Multi-Arch: foreign

 -- Drew Parsons <dparsons@debian.org>  Sat, 16 Feb 2019 11:58:54 +0800

sasmodels (0.99-1) experimental; urgency=medium

  * New upstream release.
  * Standards-Version: 4.3.0
  * debhelper compatibility level 12

 -- Drew Parsons <dparsons@debian.org>  Fri, 15 Feb 2019 17:53:42 +0800

sasmodels (0.98-1) unstable; urgency=medium

  * New upstream release.
    - refresh patches
  * Add patch to make C modules reproducible
  * Update Standards-Version to 4.2.1 (no changes required).

 -- Stuart Prescott <stuart@debian.org>  Sat, 06 Oct 2018 12:30:23 +1000

sasmodels (0.97-1) unstable; urgency=medium

  * New upstream release.

 -- Stuart Prescott <stuart@debian.org>  Tue, 24 Jul 2018 22:33:25 +1000

sasmodels (0.97~git20180309-1) unstable; urgency=medium

  * New upstream git snapshot.
    - refresh patches
    - drop disable-failing-test.patch, no longer required
  * Update test runners to use pytest rather than custom scripts.
  * Allow documentation to be built in parallel.
  * Move pyopencl packages to Recommends since the recompiled (CPU) models
    can be used rather than the OpenCL (GPU) models.

 -- Stuart Prescott <stuart@debian.org>  Sat, 10 Mar 2018 19:07:00 +1100

sasmodels (0.97~git20171104-2) unstable; urgency=medium

  * Precompile models using 'dll' mode and include them in the packages.
    - add a new binary package sasmodels-private-libs for the objects.
  * Update to debhelper compat 11.
    - relocate documentation to /usr/share/doc/sasmodels/
  * Update Standards-Version to 4.1.3 (no changes required).
  * Prevent crashes when removing pyc files from /usr/lib fails.
  * Stop using openmp on compiled models.

 -- Stuart Prescott <stuart@debian.org>  Fri, 05 Jan 2018 23:48:36 +1100

sasmodels (0.97~git20171104-1) unstable; urgency=medium

  * New upstream git snapshot.
    - Drop python3-compat.patch that was cherry-picked from upstream
    - Update copyright information
  * Build-depend on newer sphinx to ensure documentation is found during the
    sasview build.

 -- Stuart Prescott <stuart@debian.org>  Mon, 06 Nov 2017 23:42:54 +1100

sasmodels (0.96-1) unstable; urgency=medium

  * Initial release.

 -- Stuart Prescott <stuart@debian.org>  Tue, 31 Oct 2017 09:41:15 +1100