1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
#!/bin/sh
set -e
if [ "$1" = "configure" ]; then
if [ -e /etc/X11/sawfish/defaults.jl ]; then
mv /etc/X11/sawfish/defaults.jl /etc/X11/sawfish/site-init.d/00debian.jl
fi
if [ -e /etc/X11/sawfish/menu.jl ]; then
mv /etc/X11/sawfish/menu.jl /etc/X11/sawfish/site-init.d/00menu.jl
fi
rm /etc/X11/sawfish/site-init.d/defaults.jl 2>/dev/null || true
rm /etc/X11/sawfish/site-init.d/menu.jl 2>/dev/null || true
rm /etc/X11/sawfish/site-init.jl 2>/dev/null || true
rm /etc/X11/sawfish/debian-menu.jl 2>/dev/null || true
find /usr/share/sawfish/lisp -name *.jlc | xargs touch
update-alternatives --install /usr/bin/x-window-manager \
x-window-manager /usr/bin/sawfish 70 \
--slave /usr/share/man/man1/x-window-manager.1.gz \
x-window-manager.1.gz /usr/share/man/man1/sawfish.1.gz
fi
exit 0
|