1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
|
From: Jeroen Dekkers <jeroen@dekkers.ch>
Date: Sat, 24 Mar 2012 22:33:59 +0100
Subject: add-makefiles
Classes/GNUmakefile | 29 +++++++++++++++++++++++++++++
GNUmakefile | 9 +++++++++
2 files changed, 38 insertions(+)
create mode 100644 Classes/GNUmakefile
create mode 100644 GNUmakefile
diff --git a/Classes/GNUmakefile b/Classes/GNUmakefile
new file mode 100644
index 0000000..625d963
@@ -0,0 +1,29 @@
+# GNUstep makefile
+include $(GNUSTEP_MAKEFILES)/common.make
+
+LIBRARY_NAME = SBJson
+
+SBJson_VERSION=2.3.2
+
+SBJson_INCLUDE_DIRS = -std=gnu99
+
+SBJson_HEADER_FILES = \
+ SBJson.h \
+ NSObject+SBJSON.h \
+ NSString+SBJSON.h \
+ SBJsonBase.h \
+ SBJsonParser.h \
+ SBJsonWriter.h
+
+SBJson_OBJC_FILES = \
+ NSObject+SBJSON.m \
+ NSString+SBJSON.m \
+ SBJsonBase.m \
+ SBJsonParser.m \
+ SBJsonWriter.m
+
+SBJson_LIBRARIES_DEPEND_UPON += -lgnustep-base -lobjc
+
+-include GNUmakefile.preamble
+include $(GNUSTEP_MAKEFILES)/library.make
+-include GNUmakefile.postamble
diff --git a/GNUmakefile b/GNUmakefile
new file mode 100644
index 0000000..22b9785
@@ -0,0 +1,9 @@
+# GNUstep makefile
+
+include $(GNUSTEP_MAKEFILES)/common.make
+
+SUBPROJECTS += Classes
+
+-include GNUmakefile.preamble
+include $(GNUSTEP_MAKEFILES)/aggregate.make
+-include GNUmakefile.postamble
|