File: schleuder-cli.gemspec

package info (click to toggle)
schleuder-cli 0.1.0-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 240 kB
  • sloc: ruby: 570; makefile: 3
file content (26 lines) | stat: -rw-r--r-- 1,077 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
# encoding: utf-8

$: << File.expand_path('../lib', __FILE__)
require 'schleuder-cli/version'

Gem::Specification.new do |s|
  s.name         = "schleuder-cli"
  s.version      = SchleuderCli::VERSION
  s.authors      = 'schleuder dev team'
  s.email        = "schleuder@nadir.org"
  s.homepage     = "https://schleuder.nadir.org/"
  s.summary      = "A command line tool to configure schleuder-lists."
  s.description  = "Schleuder-cli enables creating, configuring, and deleting schleuder-lists, subscriptions, keys, etc."
  s.files        = `git ls-files man lib README.md`.split
  s.executables  = `git ls-files bin`.split.map {|file| File.basename(file) }
  s.test_files   = `git ls-files spec/`.split
  s.platform     = Gem::Platform::RUBY
  s.require_path = 'lib'
  s.rubyforge_project = '[none]'
  # TODO: extend/replace expired cert
  #s.signing_key = "#{ENV['HOME']}/.gem/schleuder-gem-private_key.pem"
  #s.cert_chain  = ['gem-public_cert.pem']
  s.license = 'GPL-3.0'
  s.add_runtime_dependency 'thor', '~> 0'
  s.add_development_dependency 'rspec', '~> 3.5.0'
end