1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
|
export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@ --with python3 --sourcedirectory=src
override_dh_auto_configure:
./configure BINDIR="$(CURDIR)/debian/tmp/scid/usr/games" \
SHAREDIR="$(CURDIR)/debian/tmp/scid/usr/share/scid" \
OPTIMIZE="-O3 -fno-rtti -fno-exceptions" TB=""
override_dh_auto_install:
$(MAKE) install_scid
cp -R $(CURDIR)/sounds/ $(CURDIR)/debian/tmp/scid/usr/share/scid/
chmod -R -x $(CURDIR)/debian/tmp/scid/usr/share/scid/sounds/
chmod +x $(CURDIR)/debian/tmp/scid/usr/share/scid/tcl/start.tcl
chmod +x $(CURDIR)/debian/tmp/scid/usr/share/scid/tcl/options.tcl
chmod +x $(CURDIR)/debian/tmp/scid/usr/share/scid/tcl/contrib/ezsmtp/install.tcl
override_dh_install:
dh_install -Xlicense.txt
override_dh_auto_clean:
[ ! -f Makefile ] || $(MAKE) clean
rm -f config.sub config.guess Makefile a.out
dh_clean
override_dh_auto_build:
dh_auto_build -- all_scid
|