File: changelog

package info (click to toggle)
scikit-learn 0.20.2+dfsg-6
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 51,036 kB
  • sloc: python: 108,171; ansic: 8,722; cpp: 5,651; makefile: 192; sh: 40
file content (736 lines) | stat: -rw-r--r-- 26,036 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
scikit-learn (0.20.2+dfsg-6) unstable; urgency=medium

  * Team upload.
  * Skip test_check_estimator_pairwise test on armhf (another segfault)

 -- Ole Streicher <olebole@debian.org>  Mon, 28 Jan 2019 20:26:29 +0100

scikit-learn (0.20.2+dfsg-5) unstable; urgency=medium

  * Team upload.
  * Skip test_check_estimator_clones test on armhf (another segfault)

 -- Ole Streicher <olebole@debian.org>  Mon, 28 Jan 2019 14:25:52 +0100

scikit-learn (0.20.2+dfsg-4) unstable; urgency=medium

  * Team upload.
  * Skip another armhf test that leads to a segfault

 -- Ole Streicher <olebole@debian.org>  Mon, 28 Jan 2019 09:20:16 +0100

scikit-learn (0.20.2+dfsg-3) unstable; urgency=medium

  * Team upload.
  * Move skipped tests from d/rules into a patch
  * Remaining fixes
  * Verbose test output

 -- Ole Streicher <olebole@debian.org>  Sun, 27 Jan 2019 17:29:31 +0100

scikit-learn (0.20.2+dfsg-2) unstable; urgency=medium

  * Team upload.
  * Skip tests that fail on non-intel platforms. Closes: #919918

 -- Ole Streicher <olebole@debian.org>  Sun, 27 Jan 2019 11:41:13 +0100

scikit-learn (0.20.2+dfsg-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 0.20.2+dfsg
  * Rediff patches

 -- Ole Streicher <olebole@debian.org>  Sat, 26 Jan 2019 21:48:46 +0100

scikit-learn (0.20.1+dfsg-3) unstable; urgency=medium

  * Team upload.

  [ Stuart Prescott ]
  * Update Standards-Version to 4.3.0 (no changes required).
  * Move source.lintian-overrides to new location.
  * Fix short descriptions for Python modules packages to not be identical.
  * Fix location of documentation in doc-base file.

  [ Mattia Rizzolo ]
  * Fix FTBFS of the binary-arch targets.  Closes: 919409

 -- Mattia Rizzolo <mattia@debian.org>  Wed, 16 Jan 2019 14:57:47 +0100

scikit-learn (0.20.1+dfsg-2) unstable; urgency=medium

  * Team upload.

  [ Stuart Prescott ]
  * Remove broken parallel building.  Closes: #911830; MR: !1
    - remove broken parallel building.
    - use pybuild replacements rather than trying to second guess
      pybuild internal details.

  [ Mo Zhou ]
  * Fix keyword expression for ppc64el.

  [ Mattia Rizzolo ]
  * d/rules:
    + Set HOME=$(CURDIR)/tmp.  Closes: #915078
    + Manually delete some _configtest* files that appeared out of nowhere.

 -- Mattia Rizzolo <mattia@debian.org>  Sat, 12 Jan 2019 10:34:13 +0100

scikit-learn (0.20.1+dfsg-1) unstable; urgency=medium

  * New upstream bugfix
  * debian/patches
    - dropping all 00* which were cherrypicked or upstream, and refreshing
      the rest
  * cd to .pybuild to run show_versions()

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 28 Nov 2018 20:44:02 -0500

scikit-learn (0.20.0+dfsg-2) unstable; urgency=medium

  [ Yaroslav Halchenko ]
  * dump debhelper compat to 9 to ease backportability. Added a note to
    debian/README.source
    - with that it correctly places numerous examples within -doc package
      instead of a selected pure python- one
  * debian/rules
    - removed running doctests on python3 as well -- output fluctuates across
      platforms and releases
    - skip tests marked "network" (requiring download of some test datasets)
    - invoke show_versions() for all pythons before running tests
  * debian/patches
    + Skip some tests if joblib is forced into serial mode
      (from https://github.com/scikit-learn/scikit-learn/pull/12496)
      0001-BF-skip-test_backend_respected-if-joblib-is-forced-i.patch
      0002-BF-TST-skip-test_lr_liblinear_warning-in-joblib-seri.patch

  [ Mo Zhou <cdluminate@gmail.com>]
  * debian/rules
    - skip some tests which show problems on some architectures

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 07 Nov 2018 21:29:46 -0500

scikit-learn (0.20.0+dfsg-1) unstable; urgency=medium

  * Team upload.

  [ Andreas Tille <tille@debian.org> ]
  * New upstream release
    Closes: #907806
  * Move to Debian Science team maintenance
  * Maintained at salsa.debian.org
  * d/watch:
     - Point to pypi since releases are not tagged reliably at Github
     - Use repacksuffix=+dfsg, compression=xz
     - Inject '~' between version number and rc to sort real release highter
  * d/control: Use Files-Excluded to remove files from upstream source
  * d/gbp.conf: Strip default and unusual options

  [ Yangfl <mmyangfl@gmail.com> ]
  * Introduce dh_sphinxdoc (Closes: #859149)
  * Refresh d/copyright
  * Add autopkgtests
  * d/compat
    - bump debhelper compat to 11
  * d/control
    - remove deprecated X-Python*-Version fields
    - remove build dep dh-autoreconf and cython
    - add build dep dh-python
    - add build dep librsvg2-bin, python3-sphinx-gallery, python3-numpydoc,
      python3-pandas and python3-skimage, required by doc building
    - add build dep python3-doc, python-numpy-doc, python-scipy-doc and
      python-matplotlib-doc for intersphinx mappings
    - add dep libjs-{bootstrap,mathjax} for python-sklearn-doc
    - fix Recommends python3-pytest of python3-sklearn
    - switch to Python 3 doc build dep
    - bump standard to 4.2.1
  * d/patches
    - add disable-doctest.patch to prevent Python 2 doctest failure
    - add no-buttons-js.patch
    - add no-download-intersphinx-mapping.patch
    - add parallel-cythonize.patch
    - update deb_use_system_joblib to fix test failure
    - update deb_no_online_jquery
    - remove deb_optional_linkcode
  * d/rules
    - switch from python_distutils to pybuild
    - rewrite

  [ Mo Zhou <cdluminate@gmail.com> ]
  * Fixup autopkgtest for python3.

 -- Yangfl <mmyangfl@gmail.com>  Mon, 22 Oct 2018 13:34:15 +0000

scikit-learn (0.19.2-1) unstable; urgency=medium

  * Fresh upstream bugfix release (Closes: #904636)
    - supports Python 3.7
  * debian/control
    - removed transitional python-scikits-learn (Closes: #878863)

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 26 Jul 2018 10:12:10 -0400

scikit-learn (0.19.1-4) unstable; urgency=medium

  * debian/control
    - build-depends on python-pil not deprecating -imaging (Closes: #894526)

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 08 Apr 2018 10:02:12 -0400

scikit-learn (0.19.1-3) unstable; urgency=medium

  * debian/patches/changeset_6c99d797d7c71d216503612a242bffb8d006582d.diff
    to avoid regression due to forgotten in the release fix
    (see https://github.com/scikit-learn/scikit-learn/issues/9393)
    It seems that the issue is not deterministic, and although did not
    reveal itself on a buildd server, might come back.

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 04 Jan 2018 08:02:20 -0500

scikit-learn (0.19.1-2) unstable; urgency=medium

  * debian/patches/deb_precisionloss
    - to mitigate a minor failing unittest on BE platforms
      (Closes: #883473)
  * debian/control
    - boosted policy to 4.1.2 (if something to be done, report a bug)

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 04 Dec 2017 22:42:37 -0500

scikit-learn (0.19.1-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 23 Oct 2017 15:59:32 -0400

scikit-learn (0.19.0-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 11 Aug 2017 18:12:48 -0400

scikit-learn (0.19~b2-1) experimental; urgency=medium

  * Upcoming release beta
    - some deprecations in API
  * d/
    - boost compat to 9
    - boost policy to 3.9.8 (for now)
  * d/control
    - added pytest to b-depends and recommends
  * d/rules
    - for cython < 0.24 use pre-cythonized sources (to avoid FTBFS on 16.04)

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 18 Jul 2017 15:35:44 -0400

scikit-learn (0.18.1-1) unstable; urgency=medium

  * Fresh bugfix (strongly advised to upgrade) release
  * debian/patches
    - many patches updated

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 13 Nov 2016 18:52:53 -0500

scikit-learn (0.18-4) unstable; urgency=medium

  * debian/rules
    - added cythonization (from pandas) since upstream no longer stores
      pre-generated files under GIT
    - skip test_non_meta_estimators on ppc64el to avoid FTBFS

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 25 Oct 2016 08:24:18 -0400

scikit-learn (0.18-3) unstable; urgency=medium

  * debian/rules
    - skip some minor failing tests on i386 and armel for now

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 04 Oct 2016 09:41:01 -0400

scikit-learn (0.18-2) unstable; urgency=medium

  * debian/patches/deb_use_system_joblib
    sklearn started to use other submodules of joblib directly, so previous
    stub for import did not work.  Now update local namespace of the stub
    entirely with definitions from joblib.__dict__  (Closes: #839348)
  * debian/rules
    - allow joblib to parallelize to 2 processes, to overcome recent joblib
      (0.10.2) bug with 0 value

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 02 Oct 2016 09:36:31 -0400

scikit-learn (0.18-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 29 Sep 2016 21:29:45 -0400

scikit-learn (0.17.1-2) unstable; urgency=medium

  * debian/rules
    - skip test_dump tests on arm64 to prevent FTBFS - actual resolution
      is TODO
    - robustify use of xargs to not fail if no matches (e.g. upon rebuild)

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 08 Apr 2016 09:29:22 -0400

scikit-learn (0.17.1-1) unstable; urgency=medium

  * Fresh upstream bugfix release
    - few patches were picked up from upstream branch to stay compatible with
      recent scipy/numpy in debian sid.
      See https://github.com/scikit-learn/scikit-learn/pull/6401

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 18 Feb 2016 20:22:31 -0500

scikit-learn (0.17.0-4) unstable; urgency=medium

  * debian/tests/deb_tests_lower_precision
    - lowering further to 4 decimals

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 22 Dec 2015 08:51:29 -0500

scikit-learn (0.17.0-3) unstable; urgency=medium

  * debian/control
    - recommend python3- versions of packages for python3-sklearn. Thanks
      Christopher Baines
  * debian/rules
    - boost minimal Cython version for recythonization to 0.23.1.
      Should enable back bakckports on older Debian/Ubuntus
  * debian/tests/deb_tests_lower_precision
    - to lower precision of test_feature_importances to avoid FTBFS on some
      (BE) platforms

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 21 Dec 2015 21:02:16 -0500

scikit-learn (0.17.0-2) unstable; urgency=medium

  * debian/copyright
    - extended list of copyrights/licenses (Thanks Thorsten Alteholz for
      review)

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 13 Nov 2015 23:11:12 -0500

scikit-learn (0.17.0-1) unstable; urgency=medium

  * Fresh upstream release
    - should address FTBFS on 32bit and other platforms due to failing
      tests
  * debian/patches/deb_no_tinyclues_external_image
    - to not link to external images inthe documentation (privacy concern)

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 05 Nov 2015 20:47:00 -0500

scikit-learn (0.17.0~b1+git14-g4e6829c-1) unstable; urgency=medium

  * Fresh beta release + post-release fixes -- test build
    - requires joblib >= 0.9.2 (Closes: #792483)
    - if succeeds, means that failing test fixed (Closes: #797507)
  * debian/patches
    - deb_disable_google_anals to disable google tracking
    - deb_nopaypal  to refer to upstream website and not incorporate
      paypal form in the doc
    - deb_no_online_jquery  to avoid referring to online jquery
  * debian/{control,rules}
    - heavy refactoring to support python3-sklearn (Closes: #730532)
    - point to the debian branch for git repo (Closes: #792476)
    - use system-wide libjs-underscore
  * debian/compat raise to level 7 from elderly 5

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 27 Oct 2015 11:11:00 -0400

scikit-learn (0.16.1-2) unstable; urgency=medium

  * Upload to unstable (Closes: #792074)
  * debian/control
    - boosted policy to 3.9.6
    - properly dropped python-support, debian/rules was already
      using dh_ helpers (Closes: #786185)
  * debian/patches
    - Picked up from usptream 2 fixes:
      - changeset_190fe7347cfd6fab67f37c7535c4fa9b8f0870de.diff
        FIX Include PyFuncDistance attributes while pickling.
      - changeset_5e502596460014ed3adebe61e8189a60e72d3623.diff
        Fix signature not compatible with previous declaration
        (Closes: #791615)
    - deb_skip_some_tests_on_arm
      fixed it up (missing nose imports). Thanks Logan Rosen!
      (Closes: #773862)

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 10 Jul 2015 23:26:48 -0400

scikit-learn (0.16.1-1) experimental; urgency=medium

  * Fresh upstream bugfix release

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 14 Apr 2015 19:04:54 -0400

scikit-learn (0.16.0-1) experimental; urgency=medium

  * Fresh upstream release
  * debian/patches
    - deb_git_revision_cmd - use debian/github-revision.txt with github
      treeish for this release (TODO: automate)
    - deb_no_plot_gallery - do not build gallery of example plots (some
      require network and otherwise memory/cpu intensive etc)
    - deb_optional_linkcode - would not use linkcode extension if not
      available

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 30 Mar 2015 16:11:59 -0400

scikit-learn (0.15.2-3) unstable; urgency=medium

  * debian/patches
    - deb_skip_some_tests_on_arm -- skip two tests on armv to avoid FTBFS
    - up_workaround_buggy_pil -- workaround a bug in PIL

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 07 Oct 2014 21:37:46 -0400

scikit-learn (0.15.2-2) unstable; urgency=medium

  * debian/rules
    - fixed version for comparison against sphinx. Now documentation should
      get built on recent releases (Closes: #760730).
      Thanks Federico Ceratto for the report

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 08 Sep 2014 09:47:41 -0400

scikit-learn (0.15.2-1) unstable; urgency=medium

  * Fresh upstream minor release

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 06 Sep 2014 20:11:37 -0400

scikit-learn (0.15.1-1) unstable; urgency=medium

  * Fresh upstream minor release

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 04 Aug 2014 14:10:50 -0400

scikit-learn (0.15.0-1) unstable; urgency=medium

  * Fresh upstream release
  * Build-depend on libatlas3-base

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 15 Jul 2014 08:39:08 -0400

scikit-learn (0.14.1-3) unstable; urgency=medium

  * Cherry-pick a workaround for FTBFS due to error in current scipy
    (Closes: #746096)

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 13 May 2014 10:07:58 -0400

scikit-learn (0.14.1-2) unstable; urgency=low

  * Disable reporting to google analytics -- we haven't got any permission from
    the users allowing to report back to 3rd party services
    (thanks Ambrose Andrews, Closes: #730259)

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 24 Nov 2013 10:17:29 -0500

scikit-learn (0.14.1-1) unstable; urgency=low

  * The freshiest upstream release
    - addressed 'clean -a' issue, thus removing the dh_auto_clean override
  * debian/rules
    - if available cython >= 0.19 -- re-build Cythonized sources while
      monitoring for changes using dh_autoreconf

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 08 Aug 2013 14:06:48 -0400

scikit-learn (0.14-1) UNRELEASED; urgency=low

  * The fresh upstream release
  * debian/rules
    - overload dh_auto_clean to call "clean" without -a
      (see https://github.com/scikit-learn/scikit-learn/issues/2351)
  * debian/control
    - Build-Depends:
      - multilined
      - dropped swig (not needed since awhile)
      - moved sphinx, PIL, and graphviz to Build-Depends-Indep since
        needed only for -doc package
      - do not build documentation when sphinx < 1.1.3 due to problems
        with unicode in earlier present on older Debian/Ubuntu's versions
    - boosted policy to 3.9.4 (no further changes)
    - migrate from python-support to dh_python2

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 07 Aug 2013 20:16:04 -0400

scikit-learn (0.14~a1+git20-gc9ba2c3-1) UNRELEASED; urgency=low

  * Fresh pre-release snapshot
  * debian/control
    - python-imaing to build-depends (for documentation) and removed not
      needed XS-DM-Upload-Allowed

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 05 Aug 2013 10:56:38 -0400

scikit-learn (0.13.1-1) unstable; urgency=low

  * "Fresh" bugfix release:
    - dropping all cherry picked changesets

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 01 Jun 2013 11:36:44 -0400

scikit-learn (0.13-3) unstable; urgency=low

  * Upload to unstable
  * debian/control
    - move joblib to Depends from Recommends (Closes: #709056)
  	- remove unused AFAIK XB-Python-Version

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 20 May 2013 11:01:00 -0400

scikit-learn (0.13-2) experimental; urgency=low

  * CP from upstream commits to fix a problem with ROC curves lacking
    (0,0), (1,1) trailing points in some cases (gh-1658)

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 18 Feb 2013 12:31:57 -0500

scikit-learn (0.13-1) experimental; urgency=low

  * Fresh upstream release
    - dropping CP-ed changesets and deb_disable_test_spectral_old_scipy patch
  * debian/rules
    - removing exclusion of tests previously failed

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 22 Jan 2013 21:37:24 -0500

scikit-learn (0.12.1-1) experimental; urgency=low

  * Fresh upstream bugfix release
    - for now excluded some labile tests from testing
    - picked up after release fix: 552833 Robustify LARS. Fixes issue #487

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 31 Oct 2012 16:17:41 -0400

scikit-learn (0.12.0-1) experimental; urgency=low

  * Fresh upstream release:
    - all debian/up_ patches removed, deb_ patched updated
  * Boosted policy to 3.9.3 (should be ok without changes)
  * patches/deb_disable_test_spectral_old_scipy
    - disable unittest on older scipy's due to failure
  * debian/control
    - removed obsolete (and not used any longer) python-psyco from
      Recommends

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 06 Sep 2012 21:30:31 -0400

scikit-learn (0.11.0-2) unstable; urgency=low

  * Patches to resolve FTBFS'es (Closes: #680246)
    - armel: up_inconsistent_numpy_warnings (adopted upstream)
    - mipsel: up_MinCovDet_test_seeding (picked up from upstream)

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 04 Jul 2012 11:26:24 -0400

scikit-learn (0.11.0-1) unstable; urgency=low

  * Fresh upstream release
  * Adjusted patches/deb_use_system_joblib to avoid submodule
    import
  * debian/rules:
    - run unittests in verbose mode
    - exclude 1 test with known failures (reported upstream)
      to avoid FTBFS

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 07 May 2012 22:40:04 -0400

scikit-learn (0.10.0-1) unstable; urgency=low

  * Snapshot of upstream release branch
    - Python 2.5 compatibility dropped
  * Dropping .dfsg suffix since it is not adequate.  Sources are
    repackaged only to remove joblib shipped in a separate package in Debian
    main
  * Adjusted dfsg and other rules to operate on sklearn directory
  * Dropping cherry-picked fix up_release_sv_coef_memory
  * Operate on 'requested' not all supported Python versions
  * Added 'set -e' to composite cmdline constructs in debian/rules to
    prevent swallowing errors. Thanks to Jakub Wilk for citing me the relevant
    exerpt from Debian policy ;-)

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 12 Jan 2012 22:42:03 -0500

scikit-learn (0.9.0.dfsg-1) unstable; urgency=low

  * New upstream release:
    - renamed module to sklearn,
      scikits.learn adapter was provided to ease migration
    - there is no strict dependency on IPython any longer.  Thus removed
      IPython from build-depends and Suggest it now for binary package
      (Closes: #636472)
  * Enabled all unittests and ignored failures on doctests:
    https://github.com/scikit-learn/scikit-learn/issues/401
  * Adjusted debian/copyright to be fresh DEP5-compliant

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 17 Oct 2011 23:49:47 -0400

scikit-learn (0.8.1.dfsg-1) unstable; urgency=low

  * New upstream maintenance release

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 01 Jul 2011 14:37:28 -0400

scikit-learn (0.8.0.dfsg-1) unstable; urgency=low

  * New upstream release
  * [97bc011] Boost policy compliance to 3.9.2 -- no changes
  * Included post-release fixes:
    - [f7d5317] FIX: reflect SVC API change (eps -> tol) in doc/tutorial.rst
  * Disabled unittest test_fit_works_on_sequences_of_different_length
    due to test failure during build

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 11 May 2011 10:08:13 -0400

scikit-learn (0.7.1.dfsg-3) unstable; urgency=low

  * Do not build documentation in -a mode, to prevent timeouts on buildd
    servers
  * Use JOBLIB_MULTIPROCESSING=0 to suppress use of multiprocessing by
    joblib while running tests to prevent failures in chroots without
    /dev/shm mounted

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 13 Apr 2011 17:18:46 -0400

scikit-learn (0.7.1.dfsg-2) unstable; urgency=low

  * Upload to unstable
  * Exclude objects.inv from being compressed (Closes: #608775)
  * Restrict numpy versioned dependency only to -lib package. Thanks Jakub
    Wilk

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 06 Apr 2011 14:24:35 -0400

scikit-learn (0.7.1.dfsg-1) experimental; urgency=low

  * [8972010] New upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 19 Mar 2011 11:31:00 -0400

scikit-learn (0.6.0.dfsg-1) experimental; urgency=low

  * [05f0870] Disabled use of system libsvm - scikits.learn has its own
    fork
  * [104eb54] Adjusted dfsg rule -- do not prune libsvm
  * [6b4e757] Updated copyright: DEP5 rev153, entries for cblas/ and
    lib{linear/svm}
  * [489f3a2] Extended TODO (in emacs-org mode): consider system's
    liblinear (need 1.7 with a fix)
  * Introduced .dfsg suffix to signal for difference from the pristine
    distribution of scikits.learn
  * [5dc61b3] Added README.source to describe reason(s) for .dfsg
  * [81e7f16] debian/watch: mangle debian version - remove .dfsg for
    comparisons

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 09 Jan 2011 21:01:33 -0500

scikit-learn (0.5-1) experimental; urgency=low

  * New upstream release.  Absorbed patches:
    - up_libsvm_verbosity_control
    - up_system_libsvm_no_svmhdepends
    - deb_libsvm_cythoning
  * Boost policy compliance to 3.9.1 -- no changes

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 11 Oct 2010 10:00:11 -0400

scikit-learn (0.5~rc3-1) UNRELEASED; urgency=low

  * New upstream release-candidate
    - pruning joblib in favor of external package
      added patch deb_use_system_joblib
  * New patches for upstream
    - up_libsvm_verbosity_control -- API for controlling libsvm verbosity
    - up_system_libsvm_no_svmhdepends -- do not use shipped svm.h
  * Deprecated patches:
    - up_workaround_numpy_cython_issue589652
    - deb_cython_0.12.1

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 06 Oct 2010 15:05:40 -0400

scikit-learn (0.4-3) unstable; urgency=low

  * Acknowledging Nico's NMU
  * Restricting for Python versions >= 2.5

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 06 Aug 2010 10:12:38 -0400

scikit-learn (0.4-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Call dh_numpy from debian/rules to add the correct depends for numpy in
    python:Depends (Closes: #590762)

 -- Nico Golde <nion@debian.org>  Thu, 05 Aug 2010 13:34:19 +0200

scikit-learn (0.4-2) unstable; urgency=low

  * deb_cython_0.12.1 to use code cythoned with up-to-date cython
    0.12.1
  * Build-Depend on python-numpy providing numpy-ext (Closes: #589590)
  * Policy compliance 3.9.0:
    - providing BSD license verbatim and removing references
      to deprecated BSD license file on Debian systems
  * Nosetesting without suppressing output from code
  * Workaround to allow BFS (Closes: #588595)

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 19 Jul 2010 12:32:06 -0400

scikit-learn (0.4-1) unstable; urgency=low

  * Fresh upstream release:
    - no boost library used any longer (removed from Build-Depends)
  * Moving under NeuroDebian umbrella

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 29 Jun 2010 09:32:18 -0400

scikit-learn (0.3-4) unstable; urgency=low

  * Disabling test_gmm_em unittests while building (Closes: #580879).
    Actual reason for failing tests lies within NumPy -- see #581043,
    which should be fixed there, but should not prevent building of
    this package atm.

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 10 May 2010 23:59:49 -0400

scikit-learn (0.3-3) unstable; urgency=low

  * Set HOME and MPLCONFIGDIR while unittesting as well (Closes: #580727)

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 08 May 2010 12:47:07 -0400

scikit-learn (0.3-2) unstable; urgency=low

  * Setting both HOME and MPLCONFIGDIR while building documentation
    (slipped through fingers somehow) (Closes: #580727).

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 08 May 2010 00:35:59 -0400

scikit-learn (0.3-1) unstable; urgency=low

  * Fresh upstream release.
  * Switching to use quilt for patches, debian/* tags point to detached
    debian branch
  * debian/rules:
    + build docs after python modules got built
    + additional cleanups
  * debian/control:
    + additional build-depends: python-matplotlib, ipython, swig,
      libboost-dev

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 03 May 2010 12:25:21 -0400

scikit-learn (0.2+svn625-1) unstable; urgency=low

  * Initial Debian release (Closes: #567036)
  * First ever package by me to adhere to use fresh and shiny dh.

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 07 Apr 2010 23:38:06 -0400