File: changelog

package info (click to toggle)
scram 0.16.2-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 7,984 kB
  • sloc: xml: 120,766; cpp: 23,966; python: 1,256; ansic: 100; makefile: 10
file content (81 lines) | stat: -rw-r--r-- 2,753 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
scram (0.16.2-1) unstable; urgency=medium

  * New upstream release
  * Require g++ 7.1 or later (for C++17)
  * Bump CMake required version to 3.8
  * Bump Boost required version to 1.61
  * Bump Qt required version to 5.9.1
  * Update copyright years w/ 2018
  * Update man pages
  * Add copyright to boost.scope_guard source
  * Update VCS control fields to point to Salsa

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Fri, 12 Jan 2018 04:28:58 -0800

scram (0.16.1-1) unstable; urgency=medium

  * New upstream release
  * Bump CMake required version to 3.5
  * Bump the standards version to 4.1.3
  * Remove irrelevant '-DBUILD_SHARED_LIBS' CMake build option
  * Remove 'BUILD_TESTS=OFF' build option (off by default)
  * Rename libscramcore to libscram (private library named by upstream)
  * Update manpages

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Thu, 04 Jan 2018 02:55:10 -0800

scram (0.16.0-1) unstable; urgency=medium

  [ Olzhas Rakhimov ]
  * New upstream 0.16.0
  * Drop libxml++
  * Add libxml2, qttools5-dev, qttools5-dev-tools to dependencies
  * Add GUI translations installations
  * Bump the standards version to 4.1.1
  * Update manpages

  [ S├ębastien Villemot ]
  * Fix typo in long description (Closes: #871662)

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Sat, 18 Nov 2017 17:44:50 -0800

scram (0.15.0-1) unstable; urgency=medium

  * New upstream 0.15.0
  * Remove the '.desktop' patch (pushed to upstream)
  * Drop 'dh-exec' (upstream provides renamed 'scram' completion)
  * Remove 'libscramgui.so' installation (removed by upstream)
  * Update man pages

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Mon, 14 Aug 2017 22:08:24 -0700

scram (0.14.0-1) unstable; urgency=medium

  * New upstream 0.14.0
  * Configure GUI dependencies (Qt5)
  * Boost min version bump to 1.58
  * Generate man page with help2man (manually, ironically :)
  * Standards version bump to 4.0.1
  * Bump the copyright year to 2017
  * New 'scram-gui' binary
  * Configure the packaging for multi-binary (separate & explicit install)
  * Use 'dh-exec' to rename 'scram.sh' to 'scram' upon installation
  * Override 'dh_install' to warn missing installations

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Mon, 31 Jul 2017 19:38:57 -0700

scram (0.11.5-1) unstable; urgency=medium

  * Update to new 0.11.5 upstream release
  * Remove the patch of CMakeLists.txt
    and use options provided in the new release
  * Use the man page from the doc directly
    (this had a typo in the previous release)

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Wed, 14 Dec 2016 00:27:41 -0800

scram (0.11.4-1) unstable; urgency=low

  * Initial Debian Package (Closes: #842766)

 -- Olzhas Rakhimov <ol.rakhimov@gmail.com>  Tue, 06 Dec 2016 11:27:56 +0100