File: install2.html

package info (click to toggle)
scribus-doc 1.2.1-2
  • links: PTS
  • area: non-free
  • in suites: sarge
  • size: 2,920 kB
  • ctags: 374
  • sloc: makefile: 387; xml: 110
file content (48 lines) | stat: -rw-r--r-- 2,771 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
<qt>
<title>>Requirements</title>
<h2>Requirements</h2>
<p>The programs you will need to compile Scribus are:</p>
<ol>
	<li><strong>For Scribus 1.1.2+ GCC 3.x+ is required, GCC 3.2+ is strongly recommended</strong>. The Scribus Team has tested compiling with GCC 3.4 and recommends its use, if available, for the performance benefits.</li>
	<li>autoconf 2.53+</li>
	<li>automake 1.6.3+</li>
</ol>
The dependencies for compilation, and also to run Scribus are:
<ol>
	<li>Qt 3.0.5+, both the runtime libraries and development libraries, we <strong>strongly</strong> recommend using Qt 3.3.2+.</li>
	<li>Python and python-devel libraries 2.1+.</li>
	<li>Freetype2 2.1.3+.</li>
	<li>libart_lgpl 2.3.10+, 2.3.16+ recommended.</li>
	<li>libxml 2.6+.</li>
	<li>Ghostscript &gt; 6.53+. GNU Ghostscript 7.07+ or AFPL Ghostscript 8.14 is highly recommended.</li>
	<li>Postscript-Fonts. TrueType Fonts. Scribus also can support OpenType fonts both TrueType and Type 1 Outline OpenType Fonts in 1.1.1+.</li>
</ol>
<p>Scribus will run under most any window manager and does not require KDE
itself. However, drag and drop functionality will be lost without KDE. One
of the Scribus developers runs Gnome. The author of this documentation has
made a point of testing each release of Scribus under Blackbox as well.
This has shown no incompatibilities or problems for Scribus, except for
the loss of drag and drop functionality.</p>
<p>If color management does not work, you may not have installed the
development libraries for littlecms. When downloading the package from
littlecms the make files are already configured for Linux, so compiling is
straight forward. You also need at least one RGB profile and one CMYK
profile installed or the color preferences and options will not appear in
the menus. On Red Hat and Mandrake 9.x you may have to type export
LDFLAGS=&quot;-lm&quot;, just before compiling or littlecms may not link correctly
to Scribus. This issue has been fixed in littlecms 1.10 and in Scribus 1.2</p>
<p>Testing suggests setting the correct &#034;-march=&#034; CXXFLAGS has a very
benefitial effect on Scribus performance. For example, if you have a Duron or Athlon processor, using <code>export
CXXFLAGS=&#034;-march=athlon&#034;</code> would be of benefit. Check if your distribution sets these for you and how they are set, and for further information see:
<blockquote><table width="100%" border="1" bgcolor="#eeeeee"><tr><td border="0"><small>
<pre>man gcc</pre>
</small></td></tr></table></blockquote>
for detailed options</p>
<h3>Optionally:</h3>
<ul>
<li>CUPS development librairies - Scribus now directly supports printing
with CUPS.</li>
<li>Gimp Print development librairies - Scribus now directly supports the
Gimp Print plug-in with CUPS.</li>
</ul>
</qt>