File: README.win32

package info (click to toggle)
sdlperl 1.20.3-1
  • links: PTS
  • area: main
  • in suites: sarge
  • size: 1,804 kB
  • ctags: 2,169
  • sloc: perl: 7,397; ansic: 232; makefile: 72; sh: 1
file content (77 lines) | stat: -rw-r--r-- 1,944 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
SDL_perl-1.20.2.win32
=====================

These are some (hopefully) useful comments regarding the binary release
on win32.  For any build related changes, such as details of the missing
Opengl functionality from the unix/'official' release, please see the
CHANGELOG.

Pre-requisites
--------------

You need ActiveState Perl from http://www.activestate.com/

(the win32 installer won't tell you if you haven't Perl, please check that you
can run 'PPM' before you attemt to install it!)


Upfront Install issues
----------------------

On win9x, for 'some' reason, you have to manually have close the ppm dos box 
once things have 'Finished', this doesn't effect w2k cmd.exe.

The installer takes no prisoners in terms of DLL's (I think thats normal isn't
it!), it won't care where you want them, it won't warn you if there are any
there already, and it certainly won't make a backup of any even if they are.
Understood?

The SDL DLL's and 3rd party dlls are installed into the Windows System
directory, overwriting what (if anything) was there previously, and they are:

	sdl_gfx.dll
	zlib.dll
	libpng1.dll
	sdl_image.dll
	jpeg.dll
	sdl_mixer.dll
	sdl_net.dll
	vorbisfile.dll
	ogg.dll
	sdl_sound.dll
	smpeg.dll
	vorbis.dll
	in_flac.dll
	sdl_ttf.dll
	sdl.dll
	sdl_console.dll  ('unofficial', sorry, can't remeber why, needs fixing)


Install
-------

Run the .exe. when you see all the options, go forth and explore...


Current "Issues"
----------------

1) Open GL is only at version 1.1 (I cant get the Mesa (OGL1.4) build to run
   properly, blank screen)
2) console doesn't work again... due to unaligned version changes in
   SDL_console & SDL_perl
   (or really: due to cant be arse to fixed it just yet, until someone
   complains)
3) It seems you need an internet connection for PPM to work :-( [Tels]
4) undiscovered bugs....

all the best
Wayne