1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68
|
b := $(shell pwd)/debian/sendip
arrange: arrange-stamp
arrange-stamp: install
dh_testdir
touch arrange-stamp
binary: binary-stamp
binary-stamp: binary-indep binary-arch
dh_testdir
touch binary-stamp
binary-arch: binary-arch-stamp
binary-arch-stamp: arrange
dh_testdir
dh_testroot
dh_installdocs README TODO contrib/
dh_installchangelogs CHANGES
dh_fixperms
dh_installdeb
dh_perl
dh_strip
dh_shlibdeps
dh_link
dh_compress
dh_gencontrol
dh_builddeb
touch binary-arch-stamp
binary-indep: binary-indep-stamp
binary-indep-stamp: arrange
dh_testdir
touch binary-indep-stamp
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: config
dh_testdir
$(MAKE) PREFIX=/usr LDLOADLIBS=-lc
touch build-stamp
clean:
dh_testdir
if [ -e Makefile ]; then $(MAKE) -i veryclean; fi
dh_clean arrange-stamp binary-stamp binary-arch-stamp binary-indep-stamp build-stamp config-stamp install-stamp
config: config-stamp
config-stamp:
dh_testdir
touch config-stamp
install: install-stamp
install-stamp: build
dh_testdir
install -d $(b)/usr/bin
install -d $(b)/usr/lib/sendip
install -d $(b)/usr/share/man/man1
install -c -m 755 sendip $(b)/usr/bin
install -c -m 755 *.so $(b)/usr/lib/sendip
install -c -m 644 sendip.1 $(b)/usr/share/man/man1
touch install-stamp
.PHONY: binary binary-arch binary-indep clean
|