1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
export DEB_CFLAGS_MAINT_APPEND = -Wno-sign-compare
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
BUILT_USING=$(shell dpkg-query -f '$${source:Package} (= $${source:Version}), ' -W "libsepol1-dev")
export SEPOL = /usr/lib/$(DEB_HOST_MULTIARCH)/libsepol.a
%:
dh $@ --buildsystem=pybuild --with python3
override_dh_auto_build-arch:
dh_auto_build -a -O--buildsystem=pybuild
PATH=/usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/:$(PATH) python3 setup.py build_qhc
override_dh_install:
dh_install --list-missing
override_dh_gencontrol:
dh_gencontrol -- -VBuilt-Using="$(BUILT_USING)"
override_dh_auto_test:
dh_auto_test || true
|