File: README.source

package info (click to toggle)
singular 1:4.1.1-p2+ds-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 35,860 kB
  • sloc: cpp: 288,280; ansic: 17,387; lisp: 4,242; yacc: 1,654; python: 1,608; makefile: 1,424; lex: 1,387; perl: 632; sh: 567; xml: 182
file content (21 lines) | stat: -rw-r--r-- 1,316 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
version epoch bump 0 -> 1: rationale
====================================
During the last stage of the packaging of sage for Stretch, it appeared that
the micro changes involved in singular version 4.0.3-p4 (p3 -> p4) were in fact
major changes for sage whose singular is a major dependency. As Stretch release
was approaching, the consensus among the Debian Sage Team [1] was to fix first
the manageable number of remaining issues before to jump to singular version
4.0.3-p4. Very unfortunately, singular version 4.0.3-p4 was already in
testing/Stretch when the Debian Sage Team realised this issue. Consequently,
it was decided to bump the version epoch (see deb-version(1)) in order to have
singular version 4.0.3-p3 in Stretch and to keep the Debian package versioning
flow consistent (see deb-version(1) and dpkg(1, --compare)).
In short, the version epoch bump 0 -> 1 marks the override of the package sage
over the package singular. Along this line, more recent but still incompatible
releases of singular are planned to be maintained in experimental, understood
that the Debian Sage Team will do its best to keep the gap between unstable/Sid
and experimental minimal if not vanishing.

[1] https://wiki.debian.org/DebianScience/Sage

 -- Jerome Benoit <calculus@rezozer.net>  Tue, 08 Nov 2016 14:49:46 +0000