File: changelog

package info (click to toggle)
smart-mode-line 2.13-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 596 kB
  • sloc: lisp: 1,381; makefile: 5
file content (50 lines) | stat: -rw-r--r-- 1,940 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
smart-mode-line (2.13-2) unstable; urgency=medium

  * Rebuild with dh-elpa 2.0.
  * Migrate to debhelper-compat 13.
  * Add Rules-Requires-Root: no.
  * Add 0002-Really-fix-240-Error-when-mode-line-buffer-identific.patch
    which fixes "Error during redisplay when opening calc".
  * Update my copyright years.
  * Declare Standards-Version: 4.5.1 (no changes required).

 -- Nicholas D Steeves <nsteeves@gmail.com>  Tue, 08 Dec 2020 07:07:43 -0500

smart-mode-line (2.13-1) unstable; urgency=medium

  * New upstream version.
  * Set Upstream-Contact to the email address that tagged this release.
  * Rebase 0003-Fix-privacy-breach-generic-logo-and-donation.patch
    onto upstream 2.13.
  * Drop "Enhances: emacs25" because the package was removed in buster.
  * Update my copyright years.
  * Switch to debhelper-compat 12.
  * Declare Standards-Version: 4.4.0. (No changes needed)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Mon, 08 Jul 2019 17:24:32 -0400

smart-mode-line (2.12.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patch onto upstream 2.12.0.
    - 0003-Fix-privacy-breach-generic-logo-and-donation.patch
  * debian/docs:
    - Install new screenshot-atom-one-dark.png.
    - Explicitly install README.org rather than use *.org.
  * debian/control:
    - Drop explicit ELPA dependencies for binary packages and trust dh-elpa's
      automatic dependency generation support.
    - Add Enhances: elpa-solarized-theme.
    - Refine long description.
  * Declare Standards-Version: 4.2.1.
  * Install upstream news.md as NEWS
    - debian/rules: Add override_dh_elpa to install news.md to debian/tmp/NEWS.
    - debian/docs: Drop *.md and install NEWS.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Tue, 02 Oct 2018 23:21:57 -0400

smart-mode-line (2.11.0-1) unstable; urgency=medium

  * Initial release. (Closes: #861214)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Tue, 22 May 2018 17:52:51 -0400