File: changelog

package info (click to toggle)
smart-notifier 0.28-7
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 288 kB
  • sloc: xml: 103; python: 81; makefile: 30; sh: 21
file content (214 lines) | stat: -rw-r--r-- 8,049 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
smart-notifier (0.28-7) unstable; urgency=medium

  * [6b86063] Depend on python3-gi (Closes: #986420)

 -- Chow Loong Jin <hyperair@debian.org>  Thu, 08 Apr 2021 10:41:25 +0800

smart-notifier (0.28-6) unstable; urgency=medium

  * [be9a59d] Reexport patches using newer gbp-pq and without patch numbers
  * [a7c30a3] Patch manpage to fix typos and grammatical errors.
    Thanks to Barak A. Pearlmutter (Closes: #729563)
  * [8c6d0d1] Bump Standards-Version to 3.9.5 (no changes required)
  * [d4cc66f] Bump debhelper compat and standards-version
  * [b597368] Use python3
  * [0be6397] Patch print statement for python3
  * [0783bab] Disable tests
  * [5499955] Fix typo in README.Debian
  * [3a8b5e3] Update Vcs-* urls

 -- Chow Loong Jin <hyperair@debian.org>  Fri, 22 May 2020 14:18:00 +0800

smart-notifier (0.28-5) unstable; urgency=low

  * [11fbd55] Add patch to use positional parameters for dbus (Closes: #545265)
  * [f6c4130] Port to gtk3 and GtkBuilder
  * [80d9ede] Add patch to make notification window resizable (Closes: #374719)
  * [910da00] Add patch to update deprecated dbus-glib things

 -- Chow Loong Jin <hyperair@debian.org>  Mon, 09 Jan 2012 00:58:59 +0800

smart-notifier (0.28-4) unstable; urgency=low

  * [0694cb5] Set myself as Maintainer
  * [a989894] Tidy up debian/control (alignment)
  * [03fac13] dh(1)-ize package
  * [108b884] Bump Standards-Version from 3.8.3 to 3.9.2
  * [8bd8310] DEP5-ize copyright file
  * [1c5f083] Force dh_auto_* to use python_distutils
  * [33e1a82] Add Vcs-* fields
  * [05c4d74] Switch to 3.0 (quilt)
  * [af29a38] Revert out-of-debian/ changes in diff.gz
  * [34327c0] Reapply changes in separate patches

 -- Chow Loong Jin <hyperair@debian.org>  Thu, 05 Jan 2012 05:56:33 +0800

smart-notifier (0.28-3.1) unstable; urgency=low

  * Non-maintainer upload.
  * Use dbus force-reload instead of restart on install/upgrade to avoid
    restarting X (Closes: # 639556).

 -- Osamu Aoki <osamu@debian.org>  Sat, 15 Oct 2011 12:21:42 +0900

smart-notifier (0.28-3) unstable; urgency=low

  * QA upload.
  * Convert to dh_python2 (closes: #617064).

 -- Colin Watson <cjwatson@debian.org>  Thu, 23 Jun 2011 14:41:35 +0100

smart-notifier (0.28-2) unstable; urgency=low

  * QA upload.
    + Set maintainer to Debian QA Group <packages@qa.debian.org>.
  * Acknowledge NMUs. (Closes: #511502).
  * Fix moving of egg-info file in rules. (Closes: #552914).
  * Don't capitalize false in .desktop file. (Closes: #512684, #550993).
  * Remove useless cat in 60smart-notifier. (Closes: #511504).
  * Don't build-dep on -1 revision.
  * Add appropriate copyright holder to debian/copyright.
  * Version path to GPL (GPL-2) in debian/copyright.
  * Remove empty /usr/sbin dir.
  * Add debian/pycompat and set to 2.
  * Bump debian/compat to 5 to match debhelper build-dep.
  * Bump Standards Version to 3.8.3.

 -- Barry deFreese <bdefreese@debian.org>  Fri, 30 Oct 2009 14:47:08 -0400

smart-notifier (0.28-1.3) unstable; urgency=low

  * Non-maintainer upload.
  * Build-Depend on python (>= 2.5.4) for python.mk.

 -- Kumar Appaiah <akumar@debian.org>  Mon, 19 Oct 2009 17:40:39 -0500

smart-notifier (0.28-1.2) unstable; urgency=low

  * Non-maintainer upload.
  * Fix "manipulates site-packages/ directly, failing with Python 2.6"
    Applied and uploaded Kumar's patch, thanks Dude! (Closes: #547856)i

 -- Bastian Venthur <venthur@debian.org>  Sat, 17 Oct 2009 15:10:33 +0200

smart-notifier (0.28-1.1) unstable; urgency=medium

  * Non-maintainer upload while dealing with D-Bus' CVE-2008-4311.
  * Audit the D-Bus security policy file for compatibility with D-Bus versions
    where CVE-2008-4311 has been fixed, and remove rules that appear to have
    been cargo-culted from some other package and are likely to cause
    unintended consequences for other packages (see freedesktop.org #18961).
  * Only display the SMART message if it came from the part of smart_notifier
    that only root can run, rather than allowing arbitrary local users to
    spoof arbitrary messages from smartd. (Closes: #510709)
  * Use the default Python version, and install version-independent modules
    once, rather than once per supported Python version. Not RC, but I couldn't
    bring myself to upload it without fixing this. (Closes: #507490)

 -- Simon McVittie <smcv@debian.org>  Sun, 11 Jan 2009 17:21:30 +0000

smart-notifier (0.28-1) unstable; urgency=low

  * Bump build depends on debhelper and rebuild (Closes: #383099).

 -- Brian Sutherland <jinty@web.de>  Thu,  5 Oct 2006 11:50:05 +0200

smart-notifier (0.27-1) unstable; urgency=low

  * Update to new python policy (Closes: #380953), I am forced to depend on
    python2.4-xxx packages as there is no python-dbus package.
  * Use setuptools as the build/installation system.
  * Update to standards version 3.7.2.
  * Move debhelper from Build-Depends-Indep to Build-Depends.
  * Do not exit from postinst if re-starting dbus fails, merely carry on
    regardless.
  * Depend directly on dbus as we require it and python2.4-dbus does not
    depend on it.

 -- Brian Sutherland <jinty@web.de>  Tue,  1 Aug 2006 14:07:18 +0200

smart-notifier (0.26-1) unstable; urgency=low

  * Slight documentation improvements.

 -- Brian Sutherland <jinty@web.de>  Tue,  4 Apr 2006 00:53:21 +0200

smart-notifier (0.25-1) unstable; urgency=low

  * Implement wishlist bug (closes: #360585), suggestions by Sam Morris:
        - Drop a smart-notifier.desktop file in /etc/xdg/autostart to start
          the per session user daemon on desktops implementing the freedesktop
          standard.
        - Implement the notifier using signals rather than remove calls so
          that all users running the daemon GUI's will recieve the warning.
  * Split out the GUI/daemon code into a smart_notifier.gui module.

 -- Brian Sutherland <jinty@web.de>  Mon,  3 Apr 2006 17:38:26 +0200

smart-notifier (0.24-1) unstable; urgency=low

  * Change to python2.4 (closes: #347687).
        - re-write to use python 2.4 dbus bindings.
  * Restart dbus daemon in postinst (closes: #348378).
  * Re-build package making sure to run lintian afterwards - duh!!
    (closes: #353358).

 -- Brian Sutherland <jinty@web.de>  Thu, 12 Jan 2006 14:18:48 +0100

smart-notifier (0.23-1) unstable; urgency=low

  * New upstream version: minor changes.
  * Build depend on python, rather than python2.3.
  * Pass -V to dh_python, so we don't end up with a dependency on python.
    (closes: #345617)

 -- Brian Sutherland <jinty@web.de>  Mon,  2 Jan 2006 15:09:46 +0100

smart-notifier (0.22-1) unstable; urgency=low

  * New upstream version.
  * Added a README.Debian.
  * Updated copyright information.

 -- Brian Sutherland <jinty@web.de>  Sat, 24 Dec 2005 18:25:29 +0100

smart-notifier (0.21-3) unstable; urgency=low

  * Updated standards version to 3.6.2
  * Install the smartmontools script to /etc/smartmontools rather than
    /etc/smartd, as this was what was implemted in smartmontools.
  * Added version to dependency on smartmontools.
  * Removed crufty replaces/conflicts on old diskhealthnotifier package.
  * dbus python bindings are only avaliable for python 2.3, so use and depend
    on that.

 -- Brian Sutherland <jinty@web.de>  Fri, 23 Dec 2005 12:14:20 +0100

smart-notifier (0.21-2) unstable; urgency=low

  * Added debian/TODO

 -- Brian Sutherland <jinty@web.de>  Mon,  4 Apr 2005 12:07:35 +0200

smart-notifier (0.21-1) unstable; urgency=low

  * change name to smart-notifier
  * replaces/conflicts on diskhealthnotifier

 -- Brian Sutherland <jinty@web.de>  Sun,  3 Apr 2005 20:00:09 +0200

diskhealthnotifier (0.2-1) unstable; urgency=low

  * New upstream release:
    * Change the /etc/smartd/run.d script to a bash script and add --notify
      option to smart-notifier executable. (Suggestion from Guido
      Guenther)

 -- Brian Sutherland <jinty@web.de>  Wed, 30 Mar 2005 19:17:02 +0200

diskhealthnotifier (0.1-1) unstable; urgency=low

  * Initial Release.

 -- Brian Sutherland <jinty@web.de>  Tue, 29 Mar 2005 15:47:38 +0200