1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
|
export PYBUILD_NAME=snakemake
export PYBUILD_DESTDIR_python3=debian/snakemake
export PYBUILD_BEFORE_TEST_python3=chmod +x {dir}/bin/snakemake; cp -r {dir}/bin {dir}/tests {build_dir}
export PYBUILD_AFTER_TEST_python3=rm -fr {build_dir}/bin {build_dir}/tests
export PATH:=$(shell pybuild --print build_dir --interpreter python3 --name $(PYBUILD_NAME))/bin:$(PATH)
export SPHINXBUILD=/usr/share/sphinx/scripts/python3/sphinx-build
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
PATH=$(shell pybuild --print build_dir --interpreter python3)/bin:$(PATH) \
PYTHONPATH=$(shell pybuild --print build_dir --interpreter python3) \
python3 setup.py build_sphinx
|