File: 1167.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (74 lines) | stat: -rw-r--r-- 1,243 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
Rule:

--
Sid:

1167

--
Summary:

This event is generated when an attempt is made to gain information on installed packages on OpenLINUX.

--
Impact:

This is a serious information leak, since an attack could then attempt to determine and exploit any vulnerable packages.


--
Detailed Information:

The OpenLinux CGI package comes with a script called rpm_query. A 
vulnerability exists which will allow a remote user to list all
packages/versions installed on the system. This information will be 
useful for an attacker to further compromise a system.


--
Affected Systems:

	OpenLinux Desktop 2.3        
        OpenLinux eServer 2.3        

--
Attack Scenarios:

GET http://target/cgi-bin/rpm_query HTTP/1.0

--
Ease of Attack:

Simple.

--
False Positives:

None known.

--
False Negatives:

None known.

--
Corrective Action:

Remove the package (/home/httpd/cgi-bin/rpm_query)   

Upgrade to the latest version of OpenLinux (2.3-17 or later), 

--
Contributors:
Sourcefire Research Team
Brian Caswell <bmc@sourcefire.com>
Nigel Houghton <nigel.houghton@sourcefire.com>
Snort documentation contributed by Nawapong Nakjang (tony@ksc.net, tonie@thai.com)

--
Additional References:

Bugtraq:
http://www.securityfocus.com/bid/1036

--