File: 1844.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (75 lines) | stat: -rw-r--r-- 2,010 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
Rule:

--
Sid:
1844

--
Summary:
This event is generated when a remote attacker sends an overly long
argument in the AUTHENTICATE command to an internal IMAP server,
indicating an attempt to exploit a buffer overflow vulnerability in
Netscape Messaging Server and University of Washington IMAP
implementations. This may also affect other IMAP server implementations.

--
Impact:
Remote execution of arbitrary code with the security privileges of the
IMAP process, possibly leading to remote root compromise.

--
Detailed Information:
A buffer overflow vulnerability exists in the AUTHENTICATE command in
University of Washington IMAP and Netscape Messaging Server. This can
allow a remote attacker to send an AUTHENTICATE command with a
malformed, overlong argument to a vulnerable IMAP server, causing a
buffer overflow condition. The attacker can then execute arbitrary code
on the server with the security privileges of the IMAP server process. 

--
Affected Systems:
	Netscape Messaging Server 3.55 and earlier
	University of Washington imapd 10.234 and earlier.

--
Attack Scenarios:
An attacker sends an overly long, malformed argument to an AUTHENTICATE
command to a vulnerable IMAP server, causing a buffer overflow
condition. The attacker is then able to execute arbitrary code on the
server with the security privileges of the IMAP server process.

--
Ease of Attack:
Simple. Exploits exist.

--
False Positives:
None known.

--
False Negatives:
None known.

--
Corrective Action:
Patches have been released for both UW IMAP and Netscape Messaging
Server. Apply the patch or upgrade to a Netscape Messaging Server
version higher than 3.55 or UW IMAP version higher than 10.234.

--
Contributors:
Sourcefire Vulnerability Research Team
Brian Caswell <bmc@sourcefire.com>
Sourcefire Technical Publications Team
Jennifer Harvey <jennifer.harvey@sourcefire.com>

--
Additional References:

Bugtraq
http://www.securityfocus.com/bid/130

CVE
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0005

--