File: 1864.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (61 lines) | stat: -rw-r--r-- 1,211 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
Rule:

--
Sid:
1864

--
Summary:
This event is generated when an attempt is made to enter the "SITE 
NEWER" command on an FTP server.

--
Impact:
Denial of Service. Possible execution of arbitrary code is possible.

--
Detailed Information:
When issued the "SITE NEWER" command, some versions of wu-ftpd can 
consume excessive ammounts of memory whichthen can effectively act as a 
denial of service to the entire system. If a user can create files on 
the system, it may be possible to execute code as the user running the 
ftpd daemon, typically root.

--
Affected Systems:
	wu-ftpd versions prior to and including 2.4.2.

--
Attack Scenarios:
An attacker might be trying to DoS the system, and it could lead to 
arbitrary code execution with root privileges.

--
Ease of Attack:
Medium

--
False Positives:
This can lead to false positives if the ftp service is not wu-ftpd or if
wu-ftpd is greater than version 2.4.2

--
False Negatives:
None Known

--
Corrective Action:
Upgrade the wu-ftpd service

--
Contributors:
Sourcefire Research Team
Brian Caswell <bmc@sourcefire.com>
Nigel Houghton <nigel.houghton@sourcefire.com>
Snort documentation contributed by Josh Sakofsky

-- 
Additional References:


--