File: 2318.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (67 lines) | stat: -rw-r--r-- 1,463 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
Rule:  

--
Sid:
2318

--
Summary:
This event is generated when an attempt is made to exploit a known
vulnerability in the Concurrent Versions System (CVS).

--
Impact:
Serious. Manipulation of the host file system is possible.

--
Detailed Information:
Concurrent Versions System (CVS) is used to track the history of source
code files when developing software.

Some versions of CVS contain a vulnerability that may allow an attacker
to create directories or files in the host filesystem external to the
cvsroot. This is achieved via a malformed module request.

--
Affected Systems:
	CVS versions prior to 1.11.10

--
Attack Scenarios:
An attacker may send a specially crafted request to a cvs server and
create files and directories of their choosing in the hosts root
filesystem. The attacker may then access these files at will to further
compromise the system.

--
Ease of Attack:
Simple. No exploit software is required.

--
False Positives:
None known.

--
False Negatives:
If compression is being used in data communications between the CVS
server and clients, this rule will not generate an event.

--
Corrective Action:
Apply the appropriate vendor supplied patches.

Upgrade to the latest non-affected version of the software.

--
Contributors:
Sourcefire Research Team
Brian Caswell <bmc@sourcefire.com>
Nigel Houghton <nigel.houghton@sourcefire.com>

-- 
Additional References:

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0977

--