File: 2387.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (62 lines) | stat: -rw-r--r-- 1,201 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
Rule:

--
Sid:
2387

--
Summary:
This event is generated when an attempt is made to view a URL with the string "view_broadcast.cgi" in the name.

--
Impact:
Denial of service.

--
Detailed Information:
A vulnerabilities exists in Apple Quick Time Streaming Server and
Apple Darwin Streaming Server running on Windows hosts, that may allow
a denial of service to occur.  This happens when expected parameters are not 
supplied to this script, causing the server to fail to accept new connections.

--
Affected Systems:
QuickTime/Darwin Streaming Server 4.1.3e and earlier on Windows

--
Attack Scenarios:
An attacker can craft a packet that contains a URL with the location of the view_broadcast.cgi script and not pass it required parameters.

--
Ease of Attack:
Simple

--
False Positives:
None Known

--
False Negatives:
None Known

--
Corrective Action:
Apply the appropriate patches for the systems affected.

Upgrade to the latest non affected versions of the software.

--
Contributors:
Sourcefire Research Team
Judy Novak<judy.novak@sourcefire.com>

--
Additional References:

Bugtraq:
http://www.securityfocus.com/bid/8257

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0422

--