File: 2594.txt

package info (click to toggle)
snort 2.7.0-20.4
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 34,512 kB
  • ctags: 18,772
  • sloc: ansic: 115,404; sh: 10,893; makefile: 1,372; perl: 487; sql: 213
file content (68 lines) | stat: -rw-r--r-- 1,358 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
Rule:


--
Sid:
2594


--
Summary:
This event is generated when an attempt is made to exploit a buffer overflow
associated with the Mail Transfer Agent Exim.

--
Impact:
A successful attack may allow the execution of arbitrary code on a vulnerable
server with the privilege of the process running Exim.

--
Detailed Information:
Exim is vulnerable to a buffer overflow, permitting an attacker to execute
arbitrary code.  The vulnerability may be exploited if Exim is configured to
verify header syntax in the e-mail message body.  This is not the default
configuration.  If an attacker supplies a large number of spaces after certain
header fields, it may be possible to cause a buffer overflow.

--
Affected Systems:
Exim prior to version 4.34

--
Attack Scenarios:
An attacker can create and send mail with a malformed header,
possibly causing a buffer overflow and permitting the execution of arbitrary code.

--
Ease of Attack:
Simple.

--
False Positives:
None known.

--
False Negatives:
None known.
--
Corrective Action:
Upgrade to the latest non-affected version of the software.

--
Contributors:
Sourcefire Research Team
Judy Novak <judy.novak@sourcefire.com>

--
Additional References

Bugtraq:
http://www.securityfocus.com/bid/10291

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0400

Other:
http://www.guninski.com/exim1.html

--