File: 1831.txt

package info (click to toggle)
snort 2.9.7.0-5
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid, stretch
  • size: 55,000 kB
  • ctags: 38,464
  • sloc: ansic: 266,667; sh: 12,508; makefile: 2,908; yacc: 497; perl: 496; lex: 261; sed: 14
file content (60 lines) | stat: -rw-r--r-- 1,300 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
Rule:

--
Sid:

1831

--
Summary:
This event is generated when an attempt is made to exploit a Denial of Service (DoS) condition in the Jigsaw web server from W3C.

--
Impact:
Denial of Service.

--
Detailed Information:
Jigsaw is a Java-based web server developed by W3C. Jigsaw version 2.2.1 is vulnerable to a DoS attack caused by improper handling of requests for DOS device names.

Jigsaw web server versions prior to 2.2.1 (Build 20020711)  contain a Denial of Service vulnerability in a handler that processes HTTP requests for DOS device files. This may result in process threads hanging and a consumption of all available resources.


--
Affected Systems:
	Jigsaw 2.2.1

--
Attack Scenarios:
It is possible to crash the Jigsaw web server by requesting /servlet/con about 30 times.

--
Ease of Attack:
Simple.

--
False Positives:
Certain HTTP requests may generate an event.

--
False Negatives:
None known.

--
Corrective Action:
Upgrade to the latest version of Jigsaw (2.2.1 Build 20020711 or later)

--
Contributors:
Sourcefire Research Team
Brian Caswell <bmc@sourcefire.com>
Nigel Houghton <nigel.houghton@sourcefire.com>
Snort documentation contributed by Nawapong Nakjang (tony@ksc.net, tonie@thai.com)

--
Additional References:

Bugtraq:
http://www.securityfocus.com/bid/5258/

--